aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcms
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-21 23:12:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-21 23:12:35 +0000
commit91de24a2ee0aed1e11107285a9b1f8de915641f6 (patch)
treeabd6955ab1d11f59a57fd0585317a32a770caec0 /graphics/lcms
parente2f62b48258248370a25e86dd67b81bcb3db1640 (diff)
Notes
Diffstat (limited to 'graphics/lcms')
-rw-r--r--graphics/lcms/Makefile38
-rw-r--r--graphics/lcms/files/patch-test-static9
-rw-r--r--graphics/lcms/pkg-plist2
3 files changed, 16 insertions, 33 deletions
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
index 823c9c61caeb..3746df933f2a 100644
--- a/graphics/lcms/Makefile
+++ b/graphics/lcms/Makefile
@@ -12,7 +12,10 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Light Color Management System -- a color management library
+LICENSE= MIT
+
OPTIONS_DEFINE= DOCS JPEGICC TIFFICC
+OPTIONS_SUB= yes
JPEGICC_DESC= Build color profile applier for JPEG
TIFFICC_DESC= Build color profile applier for TIFF
@@ -22,32 +25,19 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_GNOME= gnomehack lthack
USE_LDCONFIG= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MJPEGICC}
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
-CONFIGURE_ARGS+=--with-jpeg=${LOCALBASE}
-MAN1+= jpegicc.1
-PLIST_SUB+= JPEGICC=""
-.else
-CONFIGURE_ARGS+=--without-jpeg
-PLIST_SUB+= JPEGICC="@comment "
-.endif
+JPEGICC_CONFIGURE_OFF= --without-jpeg
+JPEGICC_CONFIGURE_ON= --with-jpeg=${LOCALBASE}
+JPEGICC_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+TIFFICC_CONFIGURE_OFF= --without-tiff
+TIFFICC_CONFIGURE_ON= --with-tiff=${LOCALBASE}
+TIFFICC_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
-.if ${PORT_OPTIONS:MTIFFICC}
-LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
-CONFIGURE_ARGS+=--with-tiff=${LOCALBASE}
-MAN1+= tifficc.1
-PLIST_SUB+= TIFFICC=""
-.else
-CONFIGURE_ARGS+=--without-tiff
-PLIST_SUB+= TIFFICC="@comment "
-.endif
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS = / s| python samples||' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|^testcms_LDFLAGS = .*$$|& -static|' ${WRKSRC}/testbed/Makefile.in
+# @${REINPLACE_CMD} -e '/^#ifdef __sgi/d; /^#include "sgidefs.h"/d' ${WRKSRC}/include/icc34.h.in
+ @${REINPLACE_CMD} -e '/^testcms_LDFLAGS = / s|$$| -static|' ${WRKSRC}/testbed/Makefile.in
.if !${PORT_OPTIONS:MJPEGICC}
@${REINPLACE_CMD} -e '/^SUBDIRS = / s| jpegicc||' ${WRKSRC}/Makefile.in
.endif
@@ -61,9 +51,9 @@ post-configure:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} doc/LCMSAPI.TXT doc/TUTORIAL.TXT tifficc/tifficc.c \
- jpegicc/jpegicc.c jpegicc/iccjpeg.c samples/wtpt.c samples/icctrans.c ${DOCSDIR}/
+ jpegicc/jpegicc.c jpegicc/iccjpeg.c samples/wtpt.c samples/icctrans.c ${STAGEDIR}${DOCSDIR}/
.endif
regression-test test: build
diff --git a/graphics/lcms/files/patch-test-static b/graphics/lcms/files/patch-test-static
deleted file mode 100644
index 28e3f36fd690..000000000000
--- a/graphics/lcms/files/patch-test-static
+++ /dev/null
@@ -1,9 +0,0 @@
---- testbed/Makefile.in Mon Apr 19 12:02:23 2004
-+++ testbed/Makefile.in Mon Oct 25 16:07:37 2004
-@@ -198,5 +198,5 @@
-
- testcms_LDADD = $(top_builddir)/src/liblcms.la
--testcms_LDFLAGS = @LDFLAGS@
-+testcms_LDFLAGS = @LDFLAGS@ -static
- testcms_SOURCES = testcms.c
-
diff --git a/graphics/lcms/pkg-plist b/graphics/lcms/pkg-plist
index f10c94841215..f5cd43eb5f1c 100644
--- a/graphics/lcms/pkg-plist
+++ b/graphics/lcms/pkg-plist
@@ -6,6 +6,8 @@ include/lcms.h
lib/liblcms.so
lib/liblcms.so.1
libdata/pkgconfig/lcms.pc
+%%JPEGICC%%man/man1/jpegicc.1.gz
+%%TIFFICC%%man/man1/tifficc.1.gz
%%PORTDOCS%%%%DOCSDIR%%/LCMSAPI.TXT
%%PORTDOCS%%%%DOCSDIR%%/TUTORIAL.TXT
%%PORTDOCS%%%%DOCSDIR%%/iccjpeg.c