aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcms
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-04-11 14:11:53 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-04-11 14:11:53 +0000
commit0ab420e05e75097bdc60c4d936f991acdfbf9c68 (patch)
treeeaa2300f1cedbbea2820989c4a5554e71c9e23f7 /graphics/lcms
parentd3159b32fd7043af01616573f919b8465d6b56a4 (diff)
downloadports-0ab420e05e75097bdc60c4d936f991acdfbf9c68.tar.gz
ports-0ab420e05e75097bdc60c4d936f991acdfbf9c68.zip
Notes
Diffstat (limited to 'graphics/lcms')
-rw-r--r--graphics/lcms/files/Makefile.bsd14
-rw-r--r--graphics/lcms/files/patch-aa40
-rw-r--r--graphics/lcms/files/patch-ab15
3 files changed, 14 insertions, 55 deletions
diff --git a/graphics/lcms/files/Makefile.bsd b/graphics/lcms/files/Makefile.bsd
new file mode 100644
index 000000000000..c9816d499003
--- /dev/null
+++ b/graphics/lcms/files/Makefile.bsd
@@ -0,0 +1,14 @@
+LIB=lcms
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 7
+
+SRCS!= make -f ${.CURDIR}/Makefile -V SRCS
+
+NOPROFILE=YES
+
+INCS= lcms.h icc34.h
+
+INCDIR= ${LOCALBASE}/include
+LIBDIR= ${LOCALBASE}/lib
+
+.include <bsd.lib.mk>
diff --git a/graphics/lcms/files/patch-aa b/graphics/lcms/files/patch-aa
deleted file mode 100644
index ea6e464dd212..000000000000
--- a/graphics/lcms/files/patch-aa
+++ /dev/null
@@ -1,40 +0,0 @@
---- configure Thu May 18 20:08:40 2000
-+++ configure Mon Oct 30 09:40:41 2000
-@@ -2259,35 +2259,13 @@
-
- case "$host" in
-- i?86-pc-*)
-+ i?86-*-*)
- CFLAGS="$CFLAGS -fomit-frame-pointer"
- ;;
- esac
-
--echo $ac_n "checking for __int64 type""... $ac_c" 1>&6
--echo "configure:2268: checking for __int64 type" >&5
--if test "$cross_compiling" = yes; then
-- echo "$ac_t""assuming no" 1>&6
--else
-- cat > conftest.$ac_ext <<EOF
--#line 2273 "configure"
--#include "confdefs.h"
--int main (void) { __int64 i = 0; return (i == 0);}
--EOF
--if { (eval echo configure:2277: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
--then
-+echo "using int64 on BSD" 1>&6
- cat >> confdefs.h <<\EOF
- #define USE_INT64 1
- EOF
--
-- echo "$ac_t""ok" 1>&6
--else
-- echo "configure: failed program was:" >&5
-- cat conftest.$ac_ext >&5
-- rm -fr conftest*
-- echo "$ac_t""no" 1>&6
--fi
--rm -fr conftest*
--fi
--
-
- echo $ac_n "checking for optimization""... $ac_c" 1>&6
diff --git a/graphics/lcms/files/patch-ab b/graphics/lcms/files/patch-ab
deleted file mode 100644
index 4db3b692b82e..000000000000
--- a/graphics/lcms/files/patch-ab
+++ /dev/null
@@ -1,15 +0,0 @@
---- source/cmsmtrx.c Thu May 18 18:08:13 2000
-+++ source/cmsmtrx.c Mon Oct 30 09:53:39 2000
-@@ -33,2 +33,3 @@
- #include "lcms.h"
-+#include <sys/types.h>
-
-@@ -250,3 +251,3 @@
- #ifdef USE_INT64
-- __int64 l = (__int64) a * b + 0x8000i64;
-+ u_int64_t l = (u_int64_t) a * b + (u_int64_t)0x8000;
- return (Fixed32) (l >> 16);
-@@ -711,2 +712,2 @@
- VEC3scaleAndCut(&r -> v[2], &v -> v[2], d);
--}
-+}