aboutsummaryrefslogtreecommitdiff
path: root/graphics/lensfun/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-15 18:42:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-15 18:42:10 +0000
commitbde558a465d1c8ae12ebaebf2021cd42d0fb5bfc (patch)
tree9953b46844c6b057f5730545afdfeeb331dcb0ad /graphics/lensfun/Makefile
parent7bd73040b8e358b56722a89c5fe50c4d3b796606 (diff)
downloadports-bde558a465d1c8ae12ebaebf2021cd42d0fb5bfc.tar.gz
ports-bde558a465d1c8ae12ebaebf2021cd42d0fb5bfc.zip
Notes
Diffstat (limited to 'graphics/lensfun/Makefile')
-rw-r--r--graphics/lensfun/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
index 0a00f32df16b..207403b64771 100644
--- a/graphics/lensfun/Makefile
+++ b/graphics/lensfun/Makefile
@@ -32,4 +32,8 @@ PYHELPERS_CMAKE_ON= -DSTAGEDIR:STRING=${STAGEDIR} -DPYTHON:STRING=${PYTHON_CMD}
PYHELPERS_CMAKE_OFF= -DINSTALL_HELPER_SCRIPTS:BOOL=OFF -DPYTHON:STRING=IGNORE
PYHELPERS_USES= python:3.4+
+post-patch:
+# Fix the build against Clang 6.0.0
+ @${REINPLACE_CMD} -e '/%%/s,R_BX, & ,' ${WRKSRC}/libs/lensfun/cpuid.cpp
+
.include <bsd.port.mk>