aboutsummaryrefslogtreecommitdiff
path: root/graphics/lensfun
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-12-15 11:45:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-12-15 11:45:10 +0000
commitf557e719e253e6d666696db5ec05b49cb36910dd (patch)
tree229b019914b0ebea1cbf5acc9ed54ad6866d2a92 /graphics/lensfun
parentd395618e62182e126bfa209630acd4a24aa5032e (diff)
downloadports-f557e719e253e6d666696db5ec05b49cb36910dd.tar.gz
ports-f557e719e253e6d666696db5ec05b49cb36910dd.zip
Notes
Diffstat (limited to 'graphics/lensfun')
-rw-r--r--graphics/lensfun/Makefile31
-rw-r--r--graphics/lensfun/pkg-plist8
2 files changed, 17 insertions, 22 deletions
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
index eba6598bd9d0..faf3ada4bcfd 100644
--- a/graphics/lensfun/Makefile
+++ b/graphics/lensfun/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: lensfun
+# New ports collection makefile for: LensFun
# Date created: Mon 25 May 2009 04:45:47 MSD
# Whom: Denis Barov <dindin@dindin.ru>
#
@@ -7,14 +7,14 @@
PORTNAME= lensfun
PORTVERSION= 0.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= BERLIOS
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Library for fixing lens geometry distortion
+COMMENT= Library for fixing lens geometry distortions
-LICENSE= GPLv3
+LICENSE= LGPL3
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
@@ -22,27 +22,28 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_PYTHON= yes
+USE_PYTHON_BUILD= yes
MAKEFILE= GNUmakefile
LIBVERSION= 2
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CXXFLAGS+= -I${LOCALBASE}/include
-
HAS_CONFIGURE= yes
+CONFIGURE_ENV= LD="${CXX}" AR="${AR}"
CONFIGURE_ARGS= --prefix=${PREFIX} --target=${TARGET} --vectorization=SSE
+MAKE_ARGS= V=1 # we want to know what's going on during the build
-PLIST_SUB+= PORTVERSION=${PORTVERSION} LIBVERSION=${LIBVERSION}
+PLIST_SUB+= LIBVERSION=${LIBVERSION}
-post-patch:
- @${REINPLACE_CMD} -e '1s|#!/usr/bin/python|#!/usr/bin/env python|' \
- -e 's|make --version|gmake --version|' \
- -e '/add_config_mak.*DOXYGEN/d' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e '1s|#!/usr/bin/python|#!/usr/bin/env python|' \
+ -e 's|make --version|g&|' -e '/DOXYGEN/d' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e \
's|CONF_LIBDIR)pkgconfig|CONF_LIBDIR)../libdata/pkgconfig|' \
${WRKSRC}/build/tibs/compiler/pkgconfig.mak
+ ${REINPLACE_CMD} -e '/-s -O3/d' ${WRKSRC}/build/tibs/compiler/gcc.mak
+ ${REINPLACE_CMD} -e '/GROUPS/s| DOCS||' ${WRKSRC}/build/tibs/rules.mak
post-install:
- ${LN} -sf ${PREFIX}/lib/lib${PORTNAME}.so ${PREFIX}/lib/lib${PORTNAME}.so.${LIBVERSION}
+ ${LN} -sf lib${PORTNAME}.so \
+ ${PREFIX}/lib/lib${PORTNAME}.so.${LIBVERSION}
.include <bsd.port.mk>
diff --git a/graphics/lensfun/pkg-plist b/graphics/lensfun/pkg-plist
index b7bdeffcc832..b29c993600a0 100644
--- a/graphics/lensfun/pkg-plist
+++ b/graphics/lensfun/pkg-plist
@@ -1,7 +1,7 @@
+include/lensfun.h
lib/liblensfun.so
lib/liblensfun.so.%%LIBVERSION%%
libdata/pkgconfig/lensfun.pc
-include/lensfun.h
%%DATADIR%%/6x6.xml
%%DATADIR%%/compact-canon.xml
%%DATADIR%%/compact-casio.xml
@@ -33,10 +33,4 @@ include/lensfun.h
%%DATADIR%%/slr-tamron.xml
%%DATADIR%%/slr-tokina.xml
%%DATADIR%%/slr-ussr.xml
-share/doc/lensfun-%%PORTVERSION%%/README
-share/doc/lensfun-%%PORTVERSION%%/lgpl-3.0.txt
-share/doc/lensfun-%%PORTVERSION%%/gpl-3.0.txt
-share/doc/lensfun-%%PORTVERSION%%/cc-by-sa-3.0.txt
-@dirrm share/doc/lensfun-%%PORTVERSION%%
@dirrm %%DATADIR%%
-@dirrmtry lib/pkgconfig