aboutsummaryrefslogtreecommitdiff
path: root/graphics/lensfun
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-07 21:14:06 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-07 21:14:06 +0000
commite777bb4998fc532f116e683201930cad7e3d1ece (patch)
treef9d18743ca15c6529e036c25936c207eccfc724f /graphics/lensfun
parentb4a3acf8b7ce6f399a399cb56862d083daa4aede (diff)
downloadports-e777bb4998fc532f116e683201930cad7e3d1ece.tar.gz
ports-e777bb4998fc532f116e683201930cad7e3d1ece.zip
Notes
Diffstat (limited to 'graphics/lensfun')
-rw-r--r--graphics/lensfun/Makefile6
-rw-r--r--graphics/lensfun/pkg-plist2
2 files changed, 6 insertions, 2 deletions
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
index b7940173f435..5e8c95f4caeb 100644
--- a/graphics/lensfun/Makefile
+++ b/graphics/lensfun/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lensfun
PORTVERSION= 0.2.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= BERLIOS
@@ -30,7 +31,7 @@ HAS_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ARGS= --prefix=${PREFIX} --target=${TARGET} --vectorization=SSE
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+PLIST_SUB+= PORTVERSION=${PORTVERSION} LIBVERSION=${LIBVERSION}
post-patch:
@${REINPLACE_CMD} -e '1s|#!/usr/bin/python|#!/usr/bin/env python|' \
@@ -42,4 +43,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|CONF_LIBDIR)pkgconfig|CONF_LIBDIR)../libdata/pkgconfig|g' \
${WRKSRC}/build/tibs/compiler/pkgconfig.mak
+post-install:
+ @${LN} -sf ${PREFIX}/lib/lib${PORTNAME}.so ${PREFIX}/lib/lib${PORTNAME}.so.${LIBVERSION}
+
.include <bsd.port.mk>
diff --git a/graphics/lensfun/pkg-plist b/graphics/lensfun/pkg-plist
index 793560400560..b7bdeffcc832 100644
--- a/graphics/lensfun/pkg-plist
+++ b/graphics/lensfun/pkg-plist
@@ -1,4 +1,5 @@
lib/liblensfun.so
+lib/liblensfun.so.%%LIBVERSION%%
libdata/pkgconfig/lensfun.pc
include/lensfun.h
%%DATADIR%%/6x6.xml
@@ -39,4 +40,3 @@ share/doc/lensfun-%%PORTVERSION%%/cc-by-sa-3.0.txt
@dirrm share/doc/lensfun-%%PORTVERSION%%
@dirrm %%DATADIR%%
@dirrmtry lib/pkgconfig
-@exec ln -fs lib/liblensfun.so lib/liblensfun.so.2