aboutsummaryrefslogtreecommitdiff
path: root/graphics/libGLw
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
commit92ea0d614b10bd99ce43a611721c7c4003cd79a5 (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /graphics/libGLw
parentffbb85145227efbc987e5d09cab804f896bf37f5 (diff)
downloadports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.tar.gz
ports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.zip
Notes
Diffstat (limited to 'graphics/libGLw')
-rw-r--r--graphics/libGLw/Makefile31
-rw-r--r--graphics/libGLw/distinfo6
-rw-r--r--graphics/libGLw/pkg-plist2
3 files changed, 18 insertions, 21 deletions
diff --git a/graphics/libGLw/Makefile b/graphics/libGLw/Makefile
index 45ccde00f2da..655986da0b20 100644
--- a/graphics/libGLw/Makefile
+++ b/graphics/libGLw/Makefile
@@ -1,26 +1,25 @@
-# Created by: anholt@FreeBSD.org
+# Created by: Eric Anholt <anholt@FreeBSD.org>
# $FreeBSD$
PORTNAME= libGLw
-PORTVERSION= ${MESAVERSION}
-PORTREVISION= 2
+PORTVERSION= 8.0.0
CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/glw/
+DISTNAME= glw-${PORTVERSION}
+DIST_SUBDIR= GL
+MAINTAINER= x11@FreeBSD.org
COMMENT= OpenGL widgets library
+USE_BZIP2= yes
+USES= pathfix pkgconfig
+USE_LDCONFIG= yes
USE_GL= gl
USE_MOTIF= yes
-USE_XORG= glproto xt x11 xext xxf86vm xdamage xfixes dri2proto
+USE_XORG= x11 xt xext
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static --enable-motif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-INSTALL_WRKSRC= ${WRKSRC}/src/glw
-BUILD_WRKSRC= ${WRKSRC}/src/glw
-
-.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
-
-.include <bsd.port.pre.mk>
-
-.if !(${ARCH} == "amd64" || ${ARCH} == "i386")
-CONFIGURE_ARGS+=--disable-gallium-intel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/libGLw/distinfo b/graphics/libGLw/distinfo
index 106ab0bf5805..f2e4e38a16da 100644
--- a/graphics/libGLw/distinfo
+++ b/graphics/libGLw/distinfo
@@ -1,4 +1,2 @@
-SHA256 (MesaLib-7.6.1.tar.bz2) = 701f0e4cb85d6298181651b780d1c0a439fadd02aad29ee6623fc05588bb8d44
-SIZE (MesaLib-7.6.1.tar.bz2) = 4886995
-SHA256 (MesaLib-7.11.2.tar.bz2) = 57746aa8c60bc6f5596ec6c6c7274de40fa12edce5ec33fe899e704fa00b5357
-SIZE (MesaLib-7.11.2.tar.bz2) = 6257280
+SHA256 (GL/glw-8.0.0.tar.bz2) = 2da1d06e825f073dcbad264aec7b45c649100e5bcde688ac3035b34c8dbc8597
+SIZE (GL/glw-8.0.0.tar.bz2) = 221136
diff --git a/graphics/libGLw/pkg-plist b/graphics/libGLw/pkg-plist
index 211b58674677..87418e60a81b 100644
--- a/graphics/libGLw/pkg-plist
+++ b/graphics/libGLw/pkg-plist
@@ -2,7 +2,7 @@ include/GL/GLwDrawA.h
include/GL/GLwDrawAP.h
include/GL/GLwMDrawA.h
include/GL/GLwMDrawAP.h
+lib/libGLw.la
lib/libGLw.so
lib/libGLw.so.1
libdata/pkgconfig/glw.pc
-@dirrmtry include/GL