aboutsummaryrefslogtreecommitdiff
path: root/graphics/libafterimage
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-08 16:28:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-08 16:28:17 +0000
commit79bcfeebd61929ba1e9c3a7dd95b8395c0a109aa (patch)
tree1b1b4114968a8d889731c4baa3e2a799b666184f /graphics/libafterimage
parent0b5a840b4839f23d43f0d7229e2385e120ac6058 (diff)
downloadports-79bcfeebd61929ba1e9c3a7dd95b8395c0a109aa.tar.gz
ports-79bcfeebd61929ba1e9c3a7dd95b8395c0a109aa.zip
Notes
Diffstat (limited to 'graphics/libafterimage')
-rw-r--r--graphics/libafterimage/Makefile48
-rw-r--r--graphics/libafterimage/distinfo1
-rw-r--r--graphics/libafterimage/pkg-comment1
-rw-r--r--graphics/libafterimage/pkg-descr17
-rw-r--r--graphics/libafterimage/pkg-plist34
5 files changed, 101 insertions, 0 deletions
diff --git a/graphics/libafterimage/Makefile b/graphics/libafterimage/Makefile
new file mode 100644
index 000000000000..9da4e4b7ffa3
--- /dev/null
+++ b/graphics/libafterimage/Makefile
@@ -0,0 +1,48 @@
+# ex:ts=8
+# New ports collection makefile for: libAfterImage
+# Date created: Oct 7, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libafterimage
+PORTVERSION= 0.81
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= afterstep
+DISTNAME= libAfterImage-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png \
+ ungif:${PORTSDIR}/graphics/libungif \
+ tiff:${PORTSDIR}/graphics/tiff \
+ freetype:${PORTSDIR}/print/freetype2 \
+ AfterBase:${PORTSDIR}/devel/libafterbase
+
+USE_X_PREFIX= yes
+FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ CPPFLAGS="${CXXFLAGS} `${FREETYPE_CONFIG} --cflags` -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="`${FREETYPE_CONFIG} --libs`"
+CONFIGURE_ARGS= --enable-sharedlibs --with-x
+WRKSRC= ${WRKDIR}/libAfterImage
+INSTALLS_SHLIB= yes
+
+MANCOMPRESSED= no
+MAN3= afterimage.3x asfont.3x asimage.3x asvisual.3x blender.3x import.3x
+
+post-patch:
+ @${PERL} -pi -e "s,\@CFLAGS\@,\@CPPFLAGS\@,g" ${WRKSRC}/Makefile.in
+
+pre-install:
+ @${TOUCH} ${WRKSRC}/doc/export.man
+
+post-install:
+ @${MV} -f ${PREFIX}/lib/libAfterImage.so.0.81 ${PREFIX}/lib/libAfterImage.so.0
+ @${RM} -f ${MAN3PREFIX}/man/man3/export.3x
+
+.include <bsd.port.mk>
diff --git a/graphics/libafterimage/distinfo b/graphics/libafterimage/distinfo
new file mode 100644
index 000000000000..48c9c759452d
--- /dev/null
+++ b/graphics/libafterimage/distinfo
@@ -0,0 +1 @@
+MD5 (libAfterImage-0.81.tar.gz) = 0b13bba07f9b1f7e42cd0c9713517b10
diff --git a/graphics/libafterimage/pkg-comment b/graphics/libafterimage/pkg-comment
new file mode 100644
index 000000000000..42658a8f429b
--- /dev/null
+++ b/graphics/libafterimage/pkg-comment
@@ -0,0 +1 @@
+Generic imaging library originally designed for AfterStep
diff --git a/graphics/libafterimage/pkg-descr b/graphics/libafterimage/pkg-descr
new file mode 100644
index 000000000000..ed1be57e91d4
--- /dev/null
+++ b/graphics/libafterimage/pkg-descr
@@ -0,0 +1,17 @@
+libAfterImage is the imaging library implemented for AfterStep X Window
+Manager. It has been generalized to be suitable for any application in
+need of robust graphics engine.
+
+It provides facilities for loading images from files of different formats,
+compressed in memory storage of images, scaling, tinting/shading, flipping
+and superimposition of arbitrary number of images over each other. In
+addition it allows for linear gradients drawing, and antialiased/smoothed
+text drawing using both FreeType library and X Window fonts.
+
+Primary goals of this library are to achieve exceptional quality of images
+and text, making code fast and small at the same time. Additional steps are
+taken to compensate for screen colordepth limitation, and different error
+diffusion algorithms are used to provide for smooth images even in low
+colordepth modes.
+
+WWW: http://afterstep.sourceforge.net/afterimage/
diff --git a/graphics/libafterimage/pkg-plist b/graphics/libafterimage/pkg-plist
new file mode 100644
index 000000000000..a61bf2aa5b69
--- /dev/null
+++ b/graphics/libafterimage/pkg-plist
@@ -0,0 +1,34 @@
+bin/afterimage-libs
+include/libAfterImage/afterbase.h
+include/libAfterImage/afterimage.h
+include/libAfterImage/asfont.h
+include/libAfterImage/asimage.h
+include/libAfterImage/asvisual.h
+include/libAfterImage/blender.h
+include/libAfterImage/config.h
+include/libAfterImage/export.h
+include/libAfterImage/import.h
+include/libAfterImage/xcf.h
+include/libAfterImage/xpm.h
+@dirrm include/libAfterImage
+lib/libAfterImage.a
+lib/libAfterImage.so
+lib/libAfterImage.so.0
+share/libAfterImage/doc/html/afterimage.html
+share/libAfterImage/doc/html/asflip.html
+share/libAfterImage/doc/html/asfont.html
+share/libAfterImage/doc/html/asgrad.html
+share/libAfterImage/doc/html/asimage.html
+share/libAfterImage/doc/html/asmerge.html
+share/libAfterImage/doc/html/asscale.html
+share/libAfterImage/doc/html/astext.html
+share/libAfterImage/doc/html/astile.html
+share/libAfterImage/doc/html/asview.html
+share/libAfterImage/doc/html/asvisual.html
+share/libAfterImage/doc/html/blender.html
+share/libAfterImage/doc/html/common.html
+share/libAfterImage/doc/html/export.html
+share/libAfterImage/doc/html/import.html
+@dirrm share/libAfterImage/doc/html
+@dirrm share/libAfterImage/doc
+@dirrm share/libAfterImage