aboutsummaryrefslogtreecommitdiff
path: root/graphics/libboard/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-02-22 17:40:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-02-22 17:40:29 +0000
commit567185543bf5651a11af2c00fcfd66a38a9ac41a (patch)
tree47c9741f5e2a00ebb0366dad2fbae7a26c266259 /graphics/libboard/Makefile
parentaf0745521e60aa9aecb5f8b86ecadcd28bf8673e (diff)
downloadports-567185543bf5651a11af2c00fcfd66a38a9ac41a.tar.gz
ports-567185543bf5651a11af2c00fcfd66a38a9ac41a.zip
Notes
Diffstat (limited to 'graphics/libboard/Makefile')
-rw-r--r--graphics/libboard/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/libboard/Makefile b/graphics/libboard/Makefile
index 6a8a5e72ee52..5b2617e9e813 100644
--- a/graphics/libboard/Makefile
+++ b/graphics/libboard/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= libboard
-PORTVERSION= 0.8.2
+DISTVERSION= 0.8.6b-2
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= thierry@FreeBSD.org
COMMENT= A vector graphics C++ library
+BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= CXX=${CXX}
@@ -20,12 +22,14 @@ CONFIGURE_ENV= CXX=${CXX}
USE_GMAKE= yes
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${DISTNAME:C/-.$//}
+
PORTDOCS= *
.include <bsd.port.pre.mk>
.if ${ARCH} != i386
-CFLAGS+= -fPIC
+CXXFLAGS+= -fPIC
.endif
pre-configure:
@@ -42,6 +46,7 @@ post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/
+ cd ${WRKSRC}/bin/ && ${COPYTREE_BIN} . ${EXAMPLESDIR}/
${RM} -rf ${EXAMPLESDIR}/.svn
.endif