aboutsummaryrefslogtreecommitdiff
path: root/graphics/libcdr01
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-24 11:06:57 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-24 11:06:57 +0000
commit48f459103563a7760a2eef7456e47c1fcc766973 (patch)
treee47126c6c357762b62f9e5736c3d27d12948e676 /graphics/libcdr01
parent2f52ed1ee6ec5f0804fd19cc1894bc57ce9edf01 (diff)
downloadports-48f459103563a7760a2eef7456e47c1fcc766973.tar.gz
ports-48f459103563a7760a2eef7456e47c1fcc766973.zip
- Update devel/icu to 57.1.
- Clean up the Makefile. - Follow some upstream recommendations (--with-data-packaging=archive, --disable-renaming, -DICU_NO_USER_DATA_OVERRIDE). - Patch makefiles to install static libraries with INSTALL_DATA so they aren't stripped. - Patch config/mh-bsd-gcc to sync with config/mh-linux-gcc. - Fix endianness detection in ICU. The code wanted to use BYTE_ORDER defined in machine/endian.h, but this isn't visible because ICU is compiled with _XOPEN_SOURCE. Patch the code to use _BYTE_ORDER instead. - Compile ICU with C++11 compiler to enable move constructors. - Patch ICU to fix a problem with atomics in the case of a C++11 compiler without C++11 header <atomic> (like Clang on FreeBSD 9). - Bump all ports that depend on it due to library version change. - Add USES=compiler:c++0x to some ports that pick up -std=c++0x from ICU pkgconfig files. - Add USES=compiler:c++11-lib to graphics/libcdr01 because it also needs a C++11 runtime library now. Add this to all ports that depend on it so their executables load the right libstdc++.so on FreeBSD 9. PR: 205120 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=422711
Diffstat (limited to 'graphics/libcdr01')
-rw-r--r--graphics/libcdr01/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/libcdr01/Makefile b/graphics/libcdr01/Makefile
index 126fa58455f7..3a1445b34177 100644
--- a/graphics/libcdr01/Makefile
+++ b/graphics/libcdr01/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libcdr
PORTVERSION= 0.1.3
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= LODEV
PKGNAMESUFFIX= 01
@@ -19,7 +20,7 @@ LIB_DEPENDS= libicui18n.so:devel/icu \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-tests --disable-werror --without-docs
-USES= libtool pathfix pkgconfig tar:xz
+USES= compiler:c++11-lib libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip