aboutsummaryrefslogtreecommitdiff
path: root/graphics/libdrm/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-01-05 22:57:40 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-01-05 22:57:40 +0000
commitc3c2e7cbffdd95c50e4e51af6ed725f080579b27 (patch)
tree4a30b690095b7c3b36754f571aeca80a710febd6 /graphics/libdrm/Makefile
parentb3b45538b98420f9d8207e45ca713cd7aafafc23 (diff)
downloadports-c3c2e7cbffdd95c50e4e51af6ed725f080579b27.tar.gz
ports-c3c2e7cbffdd95c50e4e51af6ed725f080579b27.zip
Notes
Diffstat (limited to 'graphics/libdrm/Makefile')
-rw-r--r--graphics/libdrm/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/graphics/libdrm/Makefile b/graphics/libdrm/Makefile
index c503232a0f77..1ff688d92a3d 100644
--- a/graphics/libdrm/Makefile
+++ b/graphics/libdrm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libdrm
-# Date created: 29 Dec 2005
-# Whom: lesi@FreeBSD.org
-#
+# Created by: lesi@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= libdrm
PORTVERSION= ${LIBDRM_VERSION}
@@ -15,8 +11,8 @@ MAINTAINER= x11@FreeBSD.org
COMMENT= Userspace interface to kernel Direct Rendering Module services
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/libpthread-stubs
-LIB_DEPENDS= pciaccess.0:${PORTSDIR}/devel/libpciaccess \
- pthread-stubs.0:${PORTSDIR}/devel/libpthread-stubs
+LIB_DEPENDS= pciaccess:${PORTSDIR}/devel/libpciaccess \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/libpthread-stubs
USE_BZIP2= yes
@@ -29,11 +25,12 @@ MAKE_JOBS_SAFE= yes
.if defined(WITH_NEW_XORG)
-OPTIONS= KMS "Enable KMS support (very experimental)" off
+OPTIONS_DEFINE= KMS
+KMS_DESC= Enable experimental KMS support
.include <bsd.port.options.mk>
-.if defined(WITH_KMS)
+.if ${PORT_OPTIONS:MKMS}
CONFIGURE_ARGS+=--enable-libkms
EXTRA_PATCHES+= ${FILESDIR}/extra-xf86drmMode.c
PLIST_SUB+= KMS=""
@@ -53,11 +50,11 @@ PLIST_SUB+= OLD="" NEW="@comment "
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "i386" || ${ARCH} == "ia64" || ${ARCH} == "powerpc"
-PLIST_SUB+= INTEL_DRIVER=""
-PLIST_SUB+= RADEON_DRIVERS=""
+PLIST_SUB+= INTEL_DRIVER=""
+PLIST_SUB+= RADEON_DRIVERS=""
.else
-PLIST_SUB+= INTEL_DRIVER="@comment "
-PLIST_SUB+= RADEON_DRIVERS="@comment "
+PLIST_SUB+= INTEL_DRIVER="@comment "
+PLIST_SUB+= RADEON_DRIVERS="@comment "
.endif
pre-patch: