aboutsummaryrefslogtreecommitdiff
path: root/graphics/libdvdread
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-28 17:36:24 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-28 17:36:24 +0000
commitcd741d997aacfeb22f217da98d6a930950325938 (patch)
tree9a4b51cf1890d9eb8239ba59e6e51eaecaa3606d /graphics/libdvdread
parentbc0c579550a767741944a29e2ec58be131e16a80 (diff)
Notes
Diffstat (limited to 'graphics/libdvdread')
-rw-r--r--graphics/libdvdread/Makefile70
-rw-r--r--graphics/libdvdread/distinfo1
-rw-r--r--graphics/libdvdread/files/extra-patch-dvdread::bswap.h17
-rw-r--r--graphics/libdvdread/files/patch-dvdread::bswap.h34
-rw-r--r--graphics/libdvdread/files/patch-ndebug35
-rw-r--r--graphics/libdvdread/pkg-comment1
-rw-r--r--graphics/libdvdread/pkg-descr3
-rw-r--r--graphics/libdvdread/pkg-plist18
8 files changed, 0 insertions, 179 deletions
diff --git a/graphics/libdvdread/Makefile b/graphics/libdvdread/Makefile
deleted file mode 100644
index 78d1f211a6c8..000000000000
--- a/graphics/libdvdread/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# New ports collection makefile for: libdvdread
-# Date created: 24 Jun 2001
-# Whom: Marc van Woerkom <3d@freebsd.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libdvdread
-PORTVERSION= 0.9.3
-CATEGORIES= graphics
-MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
-
-MAINTAINER= lioux@FreeBSD.org
-
-LIB_DEPENDS= dvdcss.${DVDCSS_LIBVERSION}:${PORTSDIR}/graphics/libdvdcss
-
-GNU_CONFIGURE= yes
-USE_LIBTOOL= yes
-USE_REINPLACE= yes
-INSTALLS_SHLIB= yes
-
-DOC_FILES= AUTHORS COPYING NEWS README TODO
-
-# ugly hack to have libdvdread directly depend on libdvdcss since
-# it already does for practical reasons even though not for compile
-# time ones
-DVDCSS_LIBVERSION= 2
-
-post-patch:
-.for p in Makefile.in dvdread/Makefile.in src/Makefile.in
- @${REINPLACE_CMD} -E -e 's|cd \$$\(top_srcdir\) && \$$\(AUTOMAKE\)|\#|; \
- s|cd \$$\(srcdir\) && \$$\(ACLOCAL\)|\#|' ${WRKSRC}/${p}
-.endfor
-# update this in sync with libdvdcss shared library version
- @${REINPLACE_CMD} -E -e 's|(libdvdcss.so).2|\1.${DVDCSS_LIBVERSION}|' \
- ${WRKSRC}/dvdread/dvd_input.c
-
-post-configure:
- @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.pre.mk>
-
-# FreeBSD byteswap optimized routines
-.if ${ARCH} == "i386"
-. if (defined(MACHINE_CPU) && ${MACHINE_CPU:Mi486} == "i486")
-WITH_OPTIMIZED_BYTESWAP=yes
-. endif
-
-. if defined(WITH_OPTIMIZED_BYTESWAP)
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-dvdread::bswap.h
-. endif
-.endif
-
-pre-everything::
-.ifndef(WITH_OPTIMIZED_BYTESWAP)
- @${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> Define WITH_OPTIMIZED_BYTESWAP to use optimized byteswap'
- @${ECHO_MSG} '===> routines. This works only in the i386 architecture, and'
- @${ECHO_MSG} '===> only with 486 processors and above.'
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/graphics/libdvdread/distinfo b/graphics/libdvdread/distinfo
deleted file mode 100644
index dc0371e87a3a..000000000000
--- a/graphics/libdvdread/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (libdvdread-0.9.3.tar.gz) = 761db1225098c0834485396d9285e5ff
diff --git a/graphics/libdvdread/files/extra-patch-dvdread::bswap.h b/graphics/libdvdread/files/extra-patch-dvdread::bswap.h
deleted file mode 100644
index 91f08856dd37..000000000000
--- a/graphics/libdvdread/files/extra-patch-dvdread::bswap.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- dvdread/bswap.h.orig Sat Nov 23 18:53:53 2002
-+++ dvdread/bswap.h Sat Nov 23 18:57:27 2002
-@@ -54,6 +54,14 @@
- * functionality!
- */
-
-+#elif defined(__FreeBSD__)
-+# define _KERNEL
-+# define I486_CPU /* Will crash unless 486+ */
-+# include <machine/endian.h>
-+# undef _KERNEL
-+# undef I486_CPU
-+# define FROM_BE_32(x) (ntohl(x))
-+
- #elif defined(__FreeBSD__) || defined(__sun) || defined(__bsdi__)
- #define B2N_16(x) \
- x = ((((x) & 0xff00) >> 8) | \
diff --git a/graphics/libdvdread/files/patch-dvdread::bswap.h b/graphics/libdvdread/files/patch-dvdread::bswap.h
deleted file mode 100644
index ad7f78b04ea8..000000000000
--- a/graphics/libdvdread/files/patch-dvdread::bswap.h
+++ /dev/null
@@ -1,34 +0,0 @@
---- dvdread/bswap.h.orig Sat Nov 23 18:53:53 2002
-+++ dvdread/bswap.h Sat Nov 23 18:56:21 2002
-@@ -22,6 +22,10 @@
-
- #include <config.h>
-
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- #if defined(WORDS_BIGENDIAN)
- /* All bigendian systems are fine, just ignore the swaps. */
- #define B2N_16(x) (void)(x)
-@@ -53,6 +57,20 @@
- * FreeBSD and Solaris don't have <byteswap.h> or any other such
- * functionality!
- */
-+
-+#elif defined(__FreeBSD__) && __FreeBSD_version >= 470000
-+#include <sys/endian.h>
-+#define B2N_16(x) x = (be16toh(x))
-+#define B2N_32(x) x = (be32toh(x))
-+#define B2N_64(x) \
-+ x = ((((x) & 0xff00000000000000) >> 56) | \
-+ (((x) & 0x00ff000000000000) >> 40) | \
-+ (((x) & 0x0000ff0000000000) >> 24) | \
-+ (((x) & 0x000000ff00000000) >> 8) | \
-+ (((x) & 0x00000000ff000000) << 8) | \
-+ (((x) & 0x0000000000ff0000) << 24) | \
-+ (((x) & 0x000000000000ff00) << 40) | \
-+ (((x) & 0x00000000000000ff) << 56))
-
- #elif defined(__FreeBSD__) || defined(__sun) || defined(__bsdi__)
- #define B2N_16(x) \
diff --git a/graphics/libdvdread/files/patch-ndebug b/graphics/libdvdread/files/patch-ndebug
deleted file mode 100644
index 2383f9ccb31b..000000000000
--- a/graphics/libdvdread/files/patch-ndebug
+++ /dev/null
@@ -1,35 +0,0 @@
---- dvdread/nav_read.c.orig Sun Apr 7 14:51:39 2002
-+++ dvdread/nav_read.c Tue Nov 5 11:47:57 2002
-@@ -27,7 +27,7 @@
- #include "nav_read.h"
-
- void navRead_PCI(pci_t *pci, unsigned char *buffer) {
-- int i, j, k;
-+ int i, j;
-
- assert(sizeof(pci_t) == PCI_BYTES - 1); // -1 for substream id
-
-@@ -71,6 +71,7 @@
- #endif
-
-
-+#ifndef NDEBUG /* { */
- /* Asserts */
-
- /* pci pci gi */
-@@ -112,6 +113,7 @@
- assert(pci->hli.btnit[n].right <= pci->hli.hl_gi.btn_ns);
- //vmcmd_verify(pci->hli.btnit[n].cmd);
- } else {
-+ int k;
- assert(pci->hli.btnit[n].btn_coln == 0);
- assert(pci->hli.btnit[n].auto_action_mode == 0);
- assert(pci->hli.btnit[n].x_start == 0);
-@@ -127,6 +129,7 @@
- }
- }
- }
-+#endif /* !NDEBUG } */
- }
-
- void navRead_DSI(dsi_t *dsi, unsigned char *buffer) {
diff --git a/graphics/libdvdread/pkg-comment b/graphics/libdvdread/pkg-comment
deleted file mode 100644
index e71becfee552..000000000000
--- a/graphics/libdvdread/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-This is needed by ogle, which is a DVD player that supports DVD menus
diff --git a/graphics/libdvdread/pkg-descr b/graphics/libdvdread/pkg-descr
deleted file mode 100644
index 150295c80db3..000000000000
--- a/graphics/libdvdread/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-This is needed by ogle, which is a DVD player that supports DVD menus
-
-WWW: http://www.dtek.chalmers.se/groups/dvd/
diff --git a/graphics/libdvdread/pkg-plist b/graphics/libdvdread/pkg-plist
deleted file mode 100644
index 639b8e18ec29..000000000000
--- a/graphics/libdvdread/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-lib/libdvdread.a
-lib/libdvdread.la
-lib/libdvdread.so
-lib/libdvdread.so.2
-include/dvdread/dvd_reader.h
-include/dvdread/ifo_types.h
-include/dvdread/ifo_read.h
-include/dvdread/ifo_print.h
-include/dvdread/nav_types.h
-include/dvdread/nav_read.h
-include/dvdread/nav_print.h
-%%PORTDOCS%%share/doc/libdvdread/AUTHORS
-%%PORTDOCS%%share/doc/libdvdread/COPYING
-%%PORTDOCS%%share/doc/libdvdread/NEWS
-%%PORTDOCS%%share/doc/libdvdread/README
-%%PORTDOCS%%share/doc/libdvdread/TODO
-%%PORTDOCS%%@dirrm share/doc/libdvdread
-@dirrm include/dvdread