aboutsummaryrefslogtreecommitdiff
path: root/graphics/libecwj2
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-24 21:07:47 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-24 21:07:47 +0000
commit74f7a90c2a0f0b038efd23365a89bfc675bbedf9 (patch)
tree81a0f0856deadb1cbe97106346dd23cd9ce9ee47 /graphics/libecwj2
parentda5a39ddf77c6efe255cff311d213a747b669ba7 (diff)
downloadports-74f7a90c2a0f0b038efd23365a89bfc675bbedf9.tar.gz
ports-74f7a90c2a0f0b038efd23365a89bfc675bbedf9.zip
Notes
Diffstat (limited to 'graphics/libecwj2')
-rw-r--r--graphics/libecwj2/Makefile15
-rw-r--r--graphics/libecwj2/files/patch-Makefile.am16
-rw-r--r--graphics/libecwj2/files/patch-configure (renamed from graphics/libecwj2/files/patch-configure.in)16
-rw-r--r--graphics/libecwj2/pkg-plist8
4 files changed, 18 insertions, 37 deletions
diff --git a/graphics/libecwj2/Makefile b/graphics/libecwj2/Makefile
index 8e4388fdf7d6..865d486d8be9 100644
--- a/graphics/libecwj2/Makefile
+++ b/graphics/libecwj2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libecwj2
PORTVERSION= 3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://glebius.int.ru/tmp/403/
DISTFILES= ecw_jpeg_2000_sdk_3_3_source.zip
@@ -14,17 +14,14 @@ COMMENT= Erdas ECW and JPEG2000 support library
RESTRICTED= Registration required to download sources,\
but sources no longer available on ERDAS website
-USE_AUTOTOOLS= libtool autoconf
+USES= gmake libtool zip
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-
-USES= gmake zip
+INSTALL_TARGET= install-strip
post-extract:
- cd ${WRKDIR} && \
- ${EXTRACT_CMD} ImageCompressionSDKSourceCode3.3Setup_20070509.zip
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/configure.in
+ (cd ${WRKDIR} && \
+ ${EXTRACT_CMD} ImageCompressionSDKSourceCode3.3Setup_20070509.zip)
+ ${TOUCH} ${WRKSRC}/Source/NCSBuildGnu/NCSGnuConfig.h.in
.include <bsd.port.mk>
diff --git a/graphics/libecwj2/files/patch-Makefile.am b/graphics/libecwj2/files/patch-Makefile.am
deleted file mode 100644
index 0ea9d5ecaeca..000000000000
--- a/graphics/libecwj2/files/patch-Makefile.am
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.am.orig 2006-07-02 20:14:18.000000000 -0500
-+++ Makefile.am 2009-03-16 14:04:13.000000000 -0500
-@@ -1,3 +1,5 @@
-+AUTOMAKE_OPTIONS = foreign
-+
- SUBDIRS = \
- Source
-
-@@ -127,7 +129,5 @@
- Source/include/gdt_pub.h \
- Source/include/gdt_stat.h \
- Source/include/pcs_erm.h \
-- Source/C/NCSEcw/lcms/include/lcms.h \
-- Source/C/NCSEcw/lcms/include/icc34.h \
- Source/NCSBuildGnu/NCSGnuConfig.h
-
diff --git a/graphics/libecwj2/files/patch-configure.in b/graphics/libecwj2/files/patch-configure
index 27d919fbe0eb..2714dc3d56c2 100644
--- a/graphics/libecwj2/files/patch-configure.in
+++ b/graphics/libecwj2/files/patch-configure
@@ -1,13 +1,13 @@
---- configure.in.orig 2010-07-29 14:03:26.000000000 +0400
-+++ configure.in 2010-07-29 14:02:39.000000000 +0400
-@@ -32,17 +32,6 @@
+--- configure.orig
++++ configure
+@@ -19897,17 +19897,6 @@
# Build some standard absolute include paths for the build
MAIN_INCLUDE_DIR="$PWD/Source/include"
-LCMS_INCLUDE_DIR="$PWD/Source/C/NCSEcw/lcms/include"
-
--# Run configure in the LCMS directory (using LCMS's own configure script)
--# to initialise any platform dependent settings that it uses
+-# Run configure in the LCMS directory (using LCMS's own configure script)
+-# to initialise any platform dependent settings that it uses
-# (e.g. typedefs for int types)
-
-THISDIR=$PWD
@@ -18,7 +18,7 @@
# Build LIBECWJ2_DEFS with all defines, and NCSGnuSystemDefs.h with defines
# needed by apps building against libecwj2.
-@@ -76,6 +65,12 @@
+@@ -19941,6 +19930,12 @@
PLATFORM_STATIC_LDFLAGS="$PLATFORM_STATIC_LDFLAGS -L/System/Library/Frameworks/Carbon.framework/Carbon"
PLATFORM_SHARED_LDFLAGS="$PLATFORM_SHARED_LDFLAGS $PLATFORM_STATIC_LDFLAGS -dynamiclib -single_module"
;;
@@ -31,12 +31,12 @@
*)
PLATFORM_DEFS=""
PLATFORM_STATIC_LDFLAGS=""
-@@ -89,7 +84,7 @@
+@@ -19954,7 +19949,7 @@
LIBECWJ2_CFLAGS="$PLATFORM_CFLAGS"
LIBECWJ2_STATIC_LDFLAGS="$PLATFORM_STATIC_LDFLAGS"
LIBECWJ2_SHARED_LDFLAGS="$PLATFORM_SHARED_LDFLAGS"
-LIBECWJ2_INCLUDES="-I$MAIN_INCLUDE_DIR -I$LCMS_INCLUDE_DIR"
-+LIBECWJ2_INCLUDES="-I$MAIN_INCLUDE_DIR -I%%LOCALBASE%%/include"
++LIBECWJ2_INCLUDES="-I$MAIN_INCLUDE_DIR"
rm -f Source/NCSBuildGnu/NCSGnuSystemDefs.h
echo "#ifndef LIBECWJ2" > Source/NCSBuildGnu/NCSGnuSystemDefs.h
diff --git a/graphics/libecwj2/pkg-plist b/graphics/libecwj2/pkg-plist
index 56c235213da1..aa5a95bbcb14 100644
--- a/graphics/libecwj2/pkg-plist
+++ b/graphics/libecwj2/pkg-plist
@@ -123,19 +123,19 @@ include/gdt_pub.h
include/gdt_stat.h
include/pcs_erm.h
lib/libNCSCnet.a
-lib/libNCSCnet.la
lib/libNCSCnet.so
lib/libNCSCnet.so.0
+lib/libNCSCnet.so.0.0.0
lib/libNCSEcw.a
-lib/libNCSEcw.la
lib/libNCSEcw.so
lib/libNCSEcw.so.0
+lib/libNCSEcw.so.0.0.0
lib/libNCSEcwC.a
-lib/libNCSEcwC.la
lib/libNCSEcwC.so
lib/libNCSEcwC.so.0
+lib/libNCSEcwC.so.0.0.0
lib/libNCSUtil.a
-lib/libNCSUtil.la
lib/libNCSUtil.so
lib/libNCSUtil.so.0
+lib/libNCSUtil.so.0.0.0
lib/libecwj2.a