aboutsummaryrefslogtreecommitdiff
path: root/graphics/libemf
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2009-02-17 01:00:44 +0000
committerMaho Nakata <maho@FreeBSD.org>2009-02-17 01:00:44 +0000
commitcd5e9f30bffaf918f484d789cad6a3304ca40530 (patch)
tree7799c4f86df653f9529efaa7531393ce3d380122 /graphics/libemf
parent40351c2d7ce389cfadfa9b3f82f7cc9f8c511b38 (diff)
Fix build on amd64.
PR: 131745 Submitted by: Tsurutani Naoki <turutani@scphys.kyoto-u.ac.jp>
Notes
Notes: svn path=/head/; revision=228526
Diffstat (limited to 'graphics/libemf')
-rw-r--r--graphics/libemf/Makefile6
-rw-r--r--graphics/libemf/files/patch-include+wine+winbase.h18
2 files changed, 18 insertions, 6 deletions
diff --git a/graphics/libemf/Makefile b/graphics/libemf/Makefile
index 19420b50e148..e07cb0cb83b8 100644
--- a/graphics/libemf/Makefile
+++ b/graphics/libemf/Makefile
@@ -18,12 +18,6 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/graphics/libemf/files/patch-include+wine+winbase.h b/graphics/libemf/files/patch-include+wine+winbase.h
new file mode 100644
index 000000000000..77f80c96200e
--- /dev/null
+++ b/graphics/libemf/files/patch-include+wine+winbase.h
@@ -0,0 +1,18 @@
+--- include/wine/winbase.h.org 2009-02-17 09:53:26.000000000 +0900
++++ include/wine/winbase.h 2009-02-17 09:54:24.000000000 +0900
+@@ -1802,6 +1802,7 @@
+ VOID WINAPI SetLastError(DWORD);
+ #endif /* __i386__ && __GNUC__ */
+
++#if !defined(__alpha__) && !defined(__amd64__) && !defined(__ia64__) && !defined(__sparc64__)
+ /* FIXME: should handle platforms where sizeof(void*) != sizeof(long) */
+ static inline PVOID WINAPI InterlockedCompareExchangePointer( PVOID *dest, PVOID xchg, PVOID compare )
+ {
+@@ -1813,6 +1814,7 @@
+ return (PVOID)InterlockedExchange( (PLONG)dest, (LONG)val );
+ }
+
++#endif
+ #ifdef __WINE__
+ #define GetCurrentProcess() ((HANDLE)0xffffffff)
+ #define GetCurrentThread() ((HANDLE)0xfffffffe)