aboutsummaryrefslogtreecommitdiff
path: root/graphics/libemf
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2004-03-30 15:07:27 +0000
committerMaho Nakata <maho@FreeBSD.org>2004-03-30 15:07:27 +0000
commitdc46905063e6db52e00768139d21c13aebd9d8b7 (patch)
tree92952cdcaea97cc3ac5417d79bd2b22b4baefdda /graphics/libemf
parentdb4e7c3acaca412f12e88bb22aad926ff0d81200 (diff)
downloadports-dc46905063e6db52e00768139d21c13aebd9d8b7.tar.gz
ports-dc46905063e6db52e00768139d21c13aebd9d8b7.zip
Notes
Diffstat (limited to 'graphics/libemf')
-rw-r--r--graphics/libemf/Makefile4
-rw-r--r--graphics/libemf/files/patch-libemf+libemf.h23
2 files changed, 23 insertions, 4 deletions
diff --git a/graphics/libemf/Makefile b/graphics/libemf/Makefile
index 86ca9a22f2b9..598babf85955 100644
--- a/graphics/libemf/Makefile
+++ b/graphics/libemf/Makefile
@@ -17,10 +17,6 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "amd64"
-BROKEN= "Does not compile on ia64 or amd64"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/graphics/libemf/files/patch-libemf+libemf.h b/graphics/libemf/files/patch-libemf+libemf.h
index c68bd22daa43..5455dfeb2459 100644
--- a/graphics/libemf/files/patch-libemf+libemf.h
+++ b/graphics/libemf/files/patch-libemf+libemf.h
@@ -1,5 +1,28 @@
--- libemf/libemf.h.orig Wed Mar 17 20:00:10 2004
+++ libemf/libemf.h Wed Mar 17 20:00:10 2004
+@@ -21,16 +21,22 @@
+ #ifndef _LIBEMF_H
+ #define _LIBEMF_H 1
+
++#include <iostream>
+ #include <cmath>
+ #include <vector>
+ #include <map>
+ #include <functional>
++#if __GNUC__ > 2
++#include <backward/function.h>
++#endif
+ #include <algorithm>
+
+ #include <config.h>
+ #include <emf.h>
+
+ #include <wine/w16.h>
++
++using namespace std;
+
+ namespace EMF {
+ /*!
@@ -338,7 +338,7 @@
fread( &dword, sizeof(DWORD), 1, fp_ );
return *this;