aboutsummaryrefslogtreecommitdiff
path: root/graphics/libepoxy
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-10-24 11:10:31 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-10-24 11:10:31 +0000
commit1bc98bdc34995efc87d70df8608f1c86f7484a9b (patch)
tree4c7c9aa621f07fbf133741bdbb05c40f4e2705f6 /graphics/libepoxy
parentbe82c889dc92d94c305c12dbdddf745d5cecec9f (diff)
downloadports-1bc98bdc34995efc87d70df8608f1c86f7484a9b.tar.gz
ports-1bc98bdc34995efc87d70df8608f1c86f7484a9b.zip
Notes
Diffstat (limited to 'graphics/libepoxy')
-rw-r--r--graphics/libepoxy/Makefile28
-rw-r--r--graphics/libepoxy/distinfo2
-rw-r--r--graphics/libepoxy/pkg-descr4
-rw-r--r--graphics/libepoxy/pkg-plist10
4 files changed, 44 insertions, 0 deletions
diff --git a/graphics/libepoxy/Makefile b/graphics/libepoxy/Makefile
new file mode 100644
index 000000000000..9527673f32bb
--- /dev/null
+++ b/graphics/libepoxy/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= libepoxy
+PORTVERSION= 1.2
+CATEGORIES= graphics
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= library that handles OpenGL function pointer managerment for you
+
+LICENSE= MIT
+
+USE_GITHUB= YES
+GH_ACCOUNT= anholt
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= 7422de5
+GH_TAGNAME= v1.2
+
+USES= autoreconf libtool pathfix pkgconfig python:3,build
+USE_XORG= xorg-macros
+USE_GL= egl glesv2
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+PATHFIX_MAKEFILEIN= Makefile.am
+
+# GLX
+USE_XORG+= x11
+
+.include <bsd.port.mk>
diff --git a/graphics/libepoxy/distinfo b/graphics/libepoxy/distinfo
new file mode 100644
index 000000000000..4d92277a4b8a
--- /dev/null
+++ b/graphics/libepoxy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libepoxy-1.2.tar.gz) = 3364f09ef5cf0c53f8879b6b6165d4d7bd82756ee44f019075fad679346be6d8
+SIZE (libepoxy-1.2.tar.gz) = 267181
diff --git a/graphics/libepoxy/pkg-descr b/graphics/libepoxy/pkg-descr
new file mode 100644
index 000000000000..533ad7fdf8b5
--- /dev/null
+++ b/graphics/libepoxy/pkg-descr
@@ -0,0 +1,4 @@
+Epoxy is a library for handling OpenGL function pointer management for
+you.
+
+WWW: https://github.com/anholt/libepoxy
diff --git a/graphics/libepoxy/pkg-plist b/graphics/libepoxy/pkg-plist
new file mode 100644
index 000000000000..ddf324377937
--- /dev/null
+++ b/graphics/libepoxy/pkg-plist
@@ -0,0 +1,10 @@
+include/epoxy/egl.h
+include/epoxy/egl_generated.h
+include/epoxy/gl.h
+include/epoxy/gl_generated.h
+include/epoxy/glx.h
+include/epoxy/glx_generated.h
+lib/libepoxy.so
+lib/libepoxy.so.0
+lib/libepoxy.so.0.0.0
+libdata/pkgconfig/epoxy.pc