aboutsummaryrefslogtreecommitdiff
path: root/graphics/libexif-gtk/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-03-28 21:21:41 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-03-28 21:21:41 +0000
commit46b7c67171451db4631159ff96c48c5716016eab (patch)
tree1b7c854762954ff5d6b3ca2dacc111565a25207b /graphics/libexif-gtk/Makefile
parentb73a2a76015fae1e9efa427630ba3fb2f6c98943 (diff)
downloadports-46b7c67171451db4631159ff96c48c5716016eab.tar.gz
ports-46b7c67171451db4631159ff96c48c5716016eab.zip
Notes
Diffstat (limited to 'graphics/libexif-gtk/Makefile')
-rw-r--r--graphics/libexif-gtk/Makefile30
1 files changed, 24 insertions, 6 deletions
diff --git a/graphics/libexif-gtk/Makefile b/graphics/libexif-gtk/Makefile
index dc8c9c288938..57eb78cf5898 100644
--- a/graphics/libexif-gtk/Makefile
+++ b/graphics/libexif-gtk/Makefile
@@ -2,25 +2,43 @@
# $FreeBSD$
PORTNAME= libexif-gtk
-PORTVERSION= 0.3.5
-PORTREVISION= 11
+PORTVERSION= 0.4.0
CATEGORIES= graphics
MASTER_SITES= SF/libexif/${PORTNAME}/${PORTVERSION}
MAINTAINER= marius@nuenneri.ch
COMMENT= GTK+ widgets to display/edit EXIF tags
-LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif
+LICENSE= LGPL21
-USES= pathfix
+LIB_DEPENDS= exif:${PORTSDIR}/graphics/libexif
+
+USES= pathfix
USE_GNOME= gtk20
USE_AUTOTOOLS= autoconf libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-D.*_DISABLE_DEPRECATED||g'
+ @${REINPLACE_CMD} 's|-g ||g' ${WRKSRC}/configure.ac
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
.include <bsd.port.mk>