aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfpx/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2007-11-02 12:42:07 +0000
committerMikhail Teterin <mi@FreeBSD.org>2007-11-02 12:42:07 +0000
commitbc25ade382f6d0273bd9340e6cc6f92c27d22267 (patch)
tree8e65ca02ae190e0ae35d8ce14570c0c8f75a74a2 /graphics/libfpx/Makefile
parent11e60f395e401f933770288b7dd78685769451d4 (diff)
downloadports-bc25ade382f6d0273bd9340e6cc6f92c27d22267.tar.gz
ports-bc25ade382f6d0273bd9340e6cc6f92c27d22267.zip
Notes
Diffstat (limited to 'graphics/libfpx/Makefile')
-rw-r--r--graphics/libfpx/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index 0528b38c57a2..7d66fda56838 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -7,20 +7,30 @@
PORTNAME= libfpx
PORTVERSION= 1.2.0.12
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ehaupt
+PATCHFILES= fpx.mega-patch.2007-11-01.bz2
+PATCH_SITES= http://aldan.algebra.com/~mi/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Library routines for working with Flashpix images
-MAKE_ARGS+= -j2
+MAKE_ARGS+= -j`${SYSCTL} -n hw.ncpu`
USE_BZIP2= yes
post-patch:
- ${RM} ${WRKSRC}/ri_image/wchar.c
+ ${RM} ${WRKSRC}/ri_image/wchar.c ${WRKSRC}/fpx/fpxlib.h
USE_LDCONFIG= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
.include <bsd.port.mk>
+
+# We want the port's Makefile to build compiler-flags from scratch
+# (based on WARNS= in particular) instead of being influenced by
+# the environment... There is no obvious way to prevent bsd.port.mk
+# from adding CFLAGS and CXXFLAGS to the build environment, so we
+# remove them here.
+MAKE_ENV:= ${MAKE_ENV:NCFLAGS=*:NCXXFLAGS=*}