aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfpx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2002-07-16 16:27:34 +0000
committerMikhail Teterin <mi@FreeBSD.org>2002-07-16 16:27:34 +0000
commit7d5b879c90402920f27ee397fabcc1677340f613 (patch)
treea9ecae4217c2ceb175150057f6d4e41fa024d001 /graphics/libfpx
parentd47ba75953b80438addd1affdb5ebd37d84f7f14 (diff)
downloadports-7d5b879c90402920f27ee397fabcc1677340f613.tar.gz
ports-7d5b879c90402920f27ee397fabcc1677340f613.zip
Notes
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/Makefile7
-rw-r--r--graphics/libfpx/files/Makefile.bsd1
2 files changed, 6 insertions, 2 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index 29a44a23f555..2dfb5993b1dc 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -31,12 +31,15 @@ MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
MAKE_ARGS+= -j2
+#CFLAGS+= -DHAVE_WCHAR_H=1 -DHAVE_DLFCN_H=1
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
post-patch:
# Replacing references to <malloc.h> with <stdlib.h>
# Ignore the /dev/stderr warning below. (What a hack!)
- ${PERL} -pi -e 's/<malloc.h>/<stdlib.h>/' \
- `find ${WRKSRC} -type f | xargs ${GREP} -l '<malloc.h>'` /dev/stderr
+ ${REINPLACE_CMD} -e 's,<malloc\.h>,<stdlib\.h>,' \
+ ${WRKSRC}/oless/h/ref.hxx ${WRKSRC}/oless/h/vect.hxx
INSTALLS_SHLIB= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
diff --git a/graphics/libfpx/files/Makefile.bsd b/graphics/libfpx/files/Makefile.bsd
index f425028c0924..65446df0aa46 100644
--- a/graphics/libfpx/files/Makefile.bsd
+++ b/graphics/libfpx/files/Makefile.bsd
@@ -7,6 +7,7 @@ LIBDIR = ${LOCALBASE}/lib
INCDIR = ${LOCALBASE}/include
NOPROFILE= Don't want it
+CFLAGS+= -DHAVE_WCHAR_H=1 -DHAVE_DLFCN_H=1 -Werror
CPPS != find ${.CURDIR} -name \*.cpp -print
# Some of the .cxx files are #include-ed into others, so can't use `find' here: