aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgaiagraphics
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-07-02 14:27:14 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-07-02 14:27:14 +0000
commit8281e34e07385cb9ea53bca0e1f1eb7af3d5bd43 (patch)
tree23a3930d124d26afcdd70e8e299868f826586143 /graphics/libgaiagraphics
parent30d172270abd4e93f16e16c6a27afec979b16385 (diff)
downloadports-8281e34e07385cb9ea53bca0e1f1eb7af3d5bd43.tar.gz
ports-8281e34e07385cb9ea53bca0e1f1eb7af3d5bd43.zip
Notes
Diffstat (limited to 'graphics/libgaiagraphics')
-rw-r--r--graphics/libgaiagraphics/Makefile35
-rw-r--r--graphics/libgaiagraphics/distinfo2
-rw-r--r--graphics/libgaiagraphics/files/patch-src-gaiagraphics_grid.c10
-rw-r--r--graphics/libgaiagraphics/pkg-descr4
-rw-r--r--graphics/libgaiagraphics/pkg-plist6
5 files changed, 57 insertions, 0 deletions
diff --git a/graphics/libgaiagraphics/Makefile b/graphics/libgaiagraphics/Makefile
new file mode 100644
index 000000000000..1f9349a65450
--- /dev/null
+++ b/graphics/libgaiagraphics/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libgaiagraphics
+# Date created: 2012-06-14
+# Whom: lbartoletti <coder@tuxfamily.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgaiagraphics
+PORTVERSION= 0.4b
+CATEGORIES= graphics geography
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Library supporting common-utility raster handling methods
+
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff \
+ geotiff:${PORTSDIR}/graphics/libgeotiff \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ cairo:${PORTSDIR}/graphics/cairo
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
+CONFIGURE_ARGS+=CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/libgaiagraphics/distinfo b/graphics/libgaiagraphics/distinfo
new file mode 100644
index 000000000000..8032c7012b00
--- /dev/null
+++ b/graphics/libgaiagraphics/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libgaiagraphics-0.4b.tar.gz) = e4ef90cc8224ecc92ad4294d4ee856b77205b19462729648c66d62b72c3b4ede
+SIZE (libgaiagraphics-0.4b.tar.gz) = 451786
diff --git a/graphics/libgaiagraphics/files/patch-src-gaiagraphics_grid.c b/graphics/libgaiagraphics/files/patch-src-gaiagraphics_grid.c
new file mode 100644
index 000000000000..b8de0cc4e058
--- /dev/null
+++ b/graphics/libgaiagraphics/files/patch-src-gaiagraphics_grid.c
@@ -0,0 +1,10 @@
+--- src/gaiagraphics_grids.c.orig 2012-07-01 18:19:38.000000000 +0200
++++ src/gaiagraphics_grids.c 2012-07-01 18:19:59.000000000 +0200
+@@ -30,6 +30,7 @@
+ #include <limits.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <sys/types.h>
+
+ #include "gaiagraphics.h"
+ #include "gaiagraphics_internals.h"
diff --git a/graphics/libgaiagraphics/pkg-descr b/graphics/libgaiagraphics/pkg-descr
new file mode 100644
index 000000000000..90bdf48f9bb1
--- /dev/null
+++ b/graphics/libgaiagraphics/pkg-descr
@@ -0,0 +1,4 @@
+libgaiagraphics is an open source library supporting common-utility
+raster handling methods.
+
+WWW: https://www.gaia-gis.it/fossil/libgaiagraphics/index
diff --git a/graphics/libgaiagraphics/pkg-plist b/graphics/libgaiagraphics/pkg-plist
new file mode 100644
index 000000000000..504cfc1403d4
--- /dev/null
+++ b/graphics/libgaiagraphics/pkg-plist
@@ -0,0 +1,6 @@
+include/gaiagraphics.h
+lib/libgaiagraphics.a
+lib/libgaiagraphics.la
+lib/libgaiagraphics.so
+lib/libgaiagraphics.so.1
+libdata/pkgconfig/gaiagraphics.pc