aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgeotiff
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-09 06:38:28 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-09 06:38:28 +0000
commit278852703fd3f5b8e61957f9aa47d041759c3892 (patch)
tree4d275e403c45c0675063e0fecd8dd2abb118190c /graphics/libgeotiff
parent687fa2a3b4be8a94a81b4fa98996b1ef9d3aa4d8 (diff)
downloadports-278852703fd3f5b8e61957f9aa47d041759c3892.tar.gz
ports-278852703fd3f5b8e61957f9aa47d041759c3892.zip
Add libgeotiff, a library for reading and writing GeoTIFF tags.
Notes
Notes: svn path=/head/; revision=150704
Diffstat (limited to 'graphics/libgeotiff')
-rw-r--r--graphics/libgeotiff/Makefile29
-rw-r--r--graphics/libgeotiff/distinfo3
-rw-r--r--graphics/libgeotiff/files/patch-Makefile.in25
-rw-r--r--graphics/libgeotiff/pkg-descr4
-rw-r--r--graphics/libgeotiff/pkg-plist51
5 files changed, 112 insertions, 0 deletions
diff --git a/graphics/libgeotiff/Makefile b/graphics/libgeotiff/Makefile
new file mode 100644
index 000000000000..16f512883635
--- /dev/null
+++ b/graphics/libgeotiff/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libgeotiff
+# Date created: 9 December 2005
+# Whom: Sam Lawrance
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgeotiff
+PORTVERSION= 1.2.2
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.remotesensing.org/pub/geotiff/libgeotiff/ \
+ http://dl1.maptools.org/dl/geotiff/libgeotiff/
+
+MAINTAINER= lawrance@FreeBSD.org
+COMMENT= Library for reading and writing GeoTIFF information tags
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ proj.5:${PORTSDIR}/graphics/proj \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+CONFIGURE_ARGS= --with-jpeg=${LOCALBASE} \
+ --with-proj=${LOCALBASE} \
+ --with-libtiff=${LOCALBASE}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/libgeotiff/distinfo b/graphics/libgeotiff/distinfo
new file mode 100644
index 000000000000..3d1e5e2a7fc7
--- /dev/null
+++ b/graphics/libgeotiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgeotiff-1.2.2.tar.gz) = 6e6bb47b6283dc63b83dcb5962e0f70a
+SHA256 (libgeotiff-1.2.2.tar.gz) = 36df81d1d741d46b805923e3519573b98a0d40a75793be0ceb2d0c31ba231d13
+SIZE (libgeotiff-1.2.2.tar.gz) = 821750
diff --git a/graphics/libgeotiff/files/patch-Makefile.in b/graphics/libgeotiff/files/patch-Makefile.in
new file mode 100644
index 000000000000..f0976a1baeeb
--- /dev/null
+++ b/graphics/libgeotiff/files/patch-Makefile.in
@@ -0,0 +1,25 @@
+--- Makefile.in.orig Mon Jan 20 18:11:03 2003
++++ Makefile.in Fri Dec 9 17:10:37 2005
+@@ -200,20 +200,7 @@
+ $(INSTALL) csv/*.csv $(DESTDIR)$(datadir)
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+ $(INSTALL) bin/listgeo$(EXEEXT) bin/geotifcp$(EXEEXT) $(DESTDIR)$(bindir)
+- if test ! -z "$(GEOTIFF_SO)" ; then \
+- if test ! -z "$(GEOTIFF_DLL)" ; then \
+- $(INSTALL) $(GEOTIFF_SO) $(DESTDIR)${bindir}; \
+- else \
+- $(INSTALL) $(GEOTIFF_SO) $(DESTDIR)${libdir}; \
+- (cd $(DESTDIR)${libdir} ; \
+- rm -f libgeotiff.so.$(VERSION_MAJOR).$(VERSION_MINOR); \
+- ${LN} $(GEOTIFF_SO) libgeotiff.so.$(VERSION_MAJOR).$(VERSION_MINOR); \
+- rm -f libgeotiff.so.$(VERSION_MAJOR); \
+- ${LN} libgeotiff.so.$(VERSION_MAJOR).$(VERSION_MINOR) \
+- libgeotiff.so.$(VERSION_MAJOR); \
+- rm -f libgeotiff.so; \
+- ${LN} libgeotiff.so.$(VERSION_MAJOR) libgeotiff.so; );\
+- fi;\
+- fi
++ $(INSTALL) $(GEOTIFF_SO) $(DESTDIR)$(libdir)/libgeotiff.so.$(VERSION_MAJOR)
++ ${LN} libgeotiff.so.$(VERSION_MAJOR) $(DESTDIR)/$(libdir)/libgeotiff.so
+
+
diff --git a/graphics/libgeotiff/pkg-descr b/graphics/libgeotiff/pkg-descr
new file mode 100644
index 000000000000..b2c7074e3f4b
--- /dev/null
+++ b/graphics/libgeotiff/pkg-descr
@@ -0,0 +1,4 @@
+Libgeotiff is a library for reading and writing GeoTIFF information tags.
+GeoTIFF is a TIFF based interchange format for georeferenced raster imagery.
+
+WWW: http://www.remotesensing.org/geotiff/
diff --git a/graphics/libgeotiff/pkg-plist b/graphics/libgeotiff/pkg-plist
new file mode 100644
index 000000000000..66f9a78bdbf3
--- /dev/null
+++ b/graphics/libgeotiff/pkg-plist
@@ -0,0 +1,51 @@
+bin/geotifcp
+bin/listgeo
+include/cpl_serv.h
+include/epsg_datum.inc
+include/epsg_ellipse.inc
+include/epsg_gcs.inc
+include/epsg_pcs.inc
+include/epsg_pm.inc
+include/epsg_proj.inc
+include/epsg_units.inc
+include/epsg_vertcs.inc
+include/geo_config.h
+include/geo_ctrans.inc
+include/geo_keyp.h
+include/geo_normalize.h
+include/geo_tiffp.h
+include/geokeys.h
+include/geokeys.inc
+include/geonames.h
+include/geotiff.h
+include/geotiffio.h
+include/geovalues.h
+include/xtiffio.h
+lib/libgeotiff.a
+lib/libgeotiff.so
+lib/libgeotiff.so.1
+share/epsg_csv/alias.csv
+share/epsg_csv/area.csv
+share/epsg_csv/change.csv
+share/epsg_csv/codes.csv
+share/epsg_csv/coordinate_axis.csv
+share/epsg_csv/coordinate_axis_name.csv
+share/epsg_csv/coordinate_operation.csv
+share/epsg_csv/coordinate_operation_method.csv
+share/epsg_csv/coordinate_operation_parameter.csv
+share/epsg_csv/coordinate_operation_parameter_value.csv
+share/epsg_csv/coordinate_operation_path.csv
+share/epsg_csv/coordinate_reference_system.csv
+share/epsg_csv/coordinate_system.csv
+share/epsg_csv/datum.csv
+share/epsg_csv/deprecation.csv
+share/epsg_csv/ellipsoid.csv
+share/epsg_csv/gcs.csv
+share/epsg_csv/naming_system.csv
+share/epsg_csv/pcs.csv
+share/epsg_csv/prime_meridian.csv
+share/epsg_csv/projop_wparm.csv
+share/epsg_csv/stateplane.csv
+share/epsg_csv/unit_of_measure.csv
+share/epsg_csv/version_history.csv
+@dirrm share/epsg_csv