aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgfx
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-25 21:18:33 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-25 21:18:33 +0000
commit93e1da9549c803127f5ae1f7d5f42fab7e364a61 (patch)
treef11743a54bafe0580c3a3aee3f54d534483090e0 /graphics/libgfx
parent80eab2817255d1ad223f18a30b0fb8fd906c29e1 (diff)
downloadports-93e1da9549c803127f5ae1f7d5f42fab7e364a61.tar.gz
ports-93e1da9549c803127f5ae1f7d5f42fab7e364a61.zip
Notes
Diffstat (limited to 'graphics/libgfx')
-rw-r--r--graphics/libgfx/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/graphics/libgfx/Makefile b/graphics/libgfx/Makefile
index abe0a1ffbdd8..a3e544079b92 100644
--- a/graphics/libgfx/Makefile
+++ b/graphics/libgfx/Makefile
@@ -12,16 +12,16 @@ COMMENT= OpenGL/FLTK development
LICENSE= MIT
-LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk \
- tiff:${PORTSDIR}/graphics/tiff \
- png15:${PORTSDIR}/graphics/png \
- gzstream:${PORTSDIR}/devel/gzstream \
- jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libgzstream.so:${PORTSDIR}/devel/gzstream \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
BUILD_WRKSRC= ${WRKSRC}/src
+USES= gmake
USE_GL= glu
-USE_GMAKE= yes
USE_XORG= x11 xext xft xinerama
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gzstream --with-libtiff-lzw --with-x
@@ -32,7 +32,6 @@ CFLAGS+= -fPIC
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
'/^CC /d ; \
@@ -45,8 +44,8 @@ post-patch:
'/^FLTK_LIBS/s|"-lfltk"|"`fltk-config --ldflags`"|' ${WRKSRC}/configure
do-install:
- @(cd ${WRKSRC}/include/gfx && ${COPYTREE_SHARE} . ${PREFIX}/include/gfx)
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${PREFIX}/lib
- @${LN} -sf ${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.0
+ @(cd ${WRKSRC}/include/gfx && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include/gfx)
+ ${INSTALL_LIB} ${WRKSRC}/src/${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib
+ @${LN} -sf ${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}.so.0
.include <bsd.port.mk>