aboutsummaryrefslogtreecommitdiff
path: root/graphics/libglapi
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-10-17 09:53:13 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-10-17 09:53:13 +0000
commit1d803f71bba5156f57c6f2ec4c16e17431b98aba (patch)
tree10eadf882ac174da154c3fda250d8872d4fa1acc /graphics/libglapi
parent655b821fe3b378492aa7ab3cc912882e4c5adb87 (diff)
downloadports-1d803f71bba5156f57c6f2ec4c16e17431b98aba.tar.gz
ports-1d803f71bba5156f57c6f2ec4c16e17431b98aba.zip
Notes
Diffstat (limited to 'graphics/libglapi')
-rw-r--r--graphics/libglapi/Makefile29
-rw-r--r--graphics/libglapi/pkg-descr2
-rw-r--r--graphics/libglapi/pkg-plist1
3 files changed, 19 insertions, 13 deletions
diff --git a/graphics/libglapi/Makefile b/graphics/libglapi/Makefile
index 5cc98d90590c..fd441c6a820c 100644
--- a/graphics/libglapi/Makefile
+++ b/graphics/libglapi/Makefile
@@ -3,29 +3,36 @@
PORTNAME= libglapi
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
+PORTREVISION= ${LIBGLAPI_REVISION}
CATEGORIES= graphics
COMMENT= Common GL api library used by Mesa based ports
-BUILD_DEPENDS= expat>=0:${PORTSDIR}/textproc/expat2 \
- libdrm>=0:${PORTSDIR}/graphics/libdrm \
- libpthread-stubs>=0:${PORTSDIR}/devel/libpthread-stubs
+LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
USE_XORG= x11 xau xcb xdmcp
# stuff not needed by libglapi but configure wants it
-USE_XORG+= glproto dri2proto dri3proto xext xdamage xfixes presentproto \
+USE_XORG+= glproto dri2proto xext xdamage xfixes presentproto \
xshmfence
-
-BUILD_WRKSRC= ${WRKSRC}/src/mapi/shared-glapi
-INSTALL_WRKSRC= ${WRKSRC}/src/mapi/shared-glapi
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libdrm.so:${PORTSDIR}/graphics/libdrm
.include <bsd.port.options.mk>
+.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
-.if ! defined(WITH_NEW_XORG)
-IGNORE= Please enable WITH_NEW_XORG, libglapi needs libdrm higher then 2.4.24
+.if defined (WITH_NEW_MESA)
+LIBGLAPI_REVISION= 0
+.else
+LIBGLAPI_REVISION= 2
+.endif
+
+.if defined (WITH_NEW_MESA)
+BUILD_WRKSRC= ${WRKSRC}/src/mapi
+INSTALL_WRKSRC= ${WRKSRC}/src/mapi
+.else
+BUILD_WRKSRC= ${WRKSRC}/src/mapi/shared-glapi
+INSTALL_WRKSRC= ${WRKSRC}/src/mapi/shared-glapi
.endif
-.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
.include <bsd.port.mk>
diff --git a/graphics/libglapi/pkg-descr b/graphics/libglapi/pkg-descr
index a7fd4a9c80cc..f0ed995240bf 100644
--- a/graphics/libglapi/pkg-descr
+++ b/graphics/libglapi/pkg-descr
@@ -1,3 +1,3 @@
-This package contains the share GL API library.
+This package contains the EGL utility library.
WWW: http://www.freedesktop.org/Software/xorg
diff --git a/graphics/libglapi/pkg-plist b/graphics/libglapi/pkg-plist
index 184b8a40f2c0..f2a3e03c9109 100644
--- a/graphics/libglapi/pkg-plist
+++ b/graphics/libglapi/pkg-plist
@@ -1,4 +1,3 @@
-lib/libglapi.la
lib/libglapi.so
lib/libglapi.so.0
lib/libglapi.so.0.0.0