aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgltf
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-07 12:20:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-07 12:20:05 +0000
commit43d09f7cc05c09ec5b50c81287381d1f80942ace (patch)
treec564f652fe1e50368b4acefbc710fb7c9283f04b /graphics/libgltf
parentb09327469fc76309a6d9a90f0f1b0674115438da (diff)
downloadports-43d09f7cc05c09ec5b50c81287381d1f80942ace.tar.gz
ports-43d09f7cc05c09ec5b50c81287381d1f80942ace.zip
Import libgltf required by libreoffice 4.3
Notes
Notes: svn path=/head/; revision=370314
Diffstat (limited to 'graphics/libgltf')
-rw-r--r--graphics/libgltf/Makefile25
-rw-r--r--graphics/libgltf/distinfo2
-rw-r--r--graphics/libgltf/pkg-descr3
-rw-r--r--graphics/libgltf/pkg-plist6
4 files changed, 36 insertions, 0 deletions
diff --git a/graphics/libgltf/Makefile b/graphics/libgltf/Makefile
new file mode 100644
index 000000000000..1ec9dadc70bd
--- /dev/null
+++ b/graphics/libgltf/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libgltf
+PORTVERSION= 0.0.2
+CATEGORIES= graphics devel
+MASTER_SITES= LODEV
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= C++ Library for rendering OpenGL models stored in glTF format
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/ptr_container/ptr_map.hpp:${PORTSDIR}/devel/boost-libs \
+ ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
+LIB_DEPENDS= libGLEW.so:${PORTSDIR}/graphics/glew
+
+USES= pathfix libtool tar:bzip2
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-werror
+INSTALL_TARGET= install-strip
+CPPFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>
diff --git a/graphics/libgltf/distinfo b/graphics/libgltf/distinfo
new file mode 100644
index 000000000000..3d72a4eb2e40
--- /dev/null
+++ b/graphics/libgltf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libgltf-0.0.2.tar.bz2) = d1cc7297ed1921aa969e26413b4c4e18afc882ce4d2f5a2aa2a2905706f7206b
+SIZE (libgltf-0.0.2.tar.bz2) = 538040
diff --git a/graphics/libgltf/pkg-descr b/graphics/libgltf/pkg-descr
new file mode 100644
index 000000000000..e4fe49131bad
--- /dev/null
+++ b/graphics/libgltf/pkg-descr
@@ -0,0 +1,3 @@
+Library for rendering OpenGL models stored in glTF format
+
+WWW: http://www.libreoffice.org
diff --git a/graphics/libgltf/pkg-plist b/graphics/libgltf/pkg-plist
new file mode 100644
index 000000000000..51aaeff58622
--- /dev/null
+++ b/graphics/libgltf/pkg-plist
@@ -0,0 +1,6 @@
+include/libgltf-0.0/libgltf.h
+include/libgltf-0.0/types.h
+lib/libgltf-0.0.so
+lib/libgltf-0.0.so.0
+lib/libgltf-0.0.so.0.0.2
+libdata/pkgconfig/libgltf-0.0.pc