aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgphoto2
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-07-28 20:12:45 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-07-28 20:12:45 +0000
commit30120a8d58b6bb1b369cecadeb114af6d8c3e76b (patch)
tree9c2512e445d7f8f4e24dde47e03c84400e2a292d /graphics/libgphoto2
parent65e97be0cfa99c7b29c744f7d4011b3ae368681e (diff)
downloadports-30120a8d58b6bb1b369cecadeb114af6d8c3e76b.tar.gz
ports-30120a8d58b6bb1b369cecadeb114af6d8c3e76b.zip
Notes
Diffstat (limited to 'graphics/libgphoto2')
-rw-r--r--graphics/libgphoto2/Makefile10
-rw-r--r--graphics/libgphoto2/distinfo4
-rw-r--r--graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h6
-rw-r--r--graphics/libgphoto2/files/patch-libgphoto2_port__libusb1__libusb1.c13
4 files changed, 23 insertions, 10 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index a80c23d0947a..5cc44c2ba92d 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libgphoto2
-PORTVERSION= 2.5.7
+PORTVERSION= 2.5.8
CATEGORIES= graphics
MASTER_SITES= SF/gphoto/libgphoto/${PORTVERSION}
@@ -10,7 +10,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Universal digital camera control library
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
+#LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
@@ -55,9 +55,9 @@ CONFIGURE_ENV+= LIBUSB1_CFLAGS=" " LIBUSB1_LIBS="-lusb"
post-patch:
.for i in configure libgphoto2_port/configure
@${REINPLACE_CMD} -e \
- 's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig| ; \
- /FLAGS/s|-g|| ; \
- /grep -i linux/s|; fi ; then|; else false; fi ; then|' \
+ '/FLAGS/s|-g|| ; \
+ /grep -i linux/s|; fi ; then|; else false; fi ; then| ; \
+ /pkgconfig/s|$${libdir}|$${prefix}/libdata|' \
${WRKSRC}/${i}
.endfor
@${REINPLACE_CMD} -e \
diff --git a/graphics/libgphoto2/distinfo b/graphics/libgphoto2/distinfo
index b16d160188ea..c20d1a34facb 100644
--- a/graphics/libgphoto2/distinfo
+++ b/graphics/libgphoto2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libgphoto2-2.5.7.tar.bz2) = 7260193277bdb4c319dd8f151224f87deac9fde64cbe5d2eb25d9c19e4d09894
-SIZE (libgphoto2-2.5.7.tar.bz2) = 6726164
+SHA256 (libgphoto2-2.5.8.tar.bz2) = 031a262e342fae43f724afe66787947ce1fb483277dfe5a8cf1fbe92c58e27b6
+SIZE (libgphoto2-2.5.8.tar.bz2) = 6941251
diff --git a/graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h b/graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h
index 6a7c17a6330f..87eae53991ac 100644
--- a/graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h
+++ b/graphics/libgphoto2/files/patch-libgphoto2_port-gphoto2-gphoto2-port-portability.h
@@ -1,6 +1,6 @@
---- libgphoto2_port/gphoto2/gphoto2-port-portability.h.orig 2011-04-05 08:38:24.000000000 +0200
-+++ libgphoto2_port/gphoto2/gphoto2-port-portability.h 2013-10-26 11:13:54.000000000 +0200
-@@ -152,20 +152,6 @@
+--- libgphoto2_port/gphoto2/gphoto2-port-portability.h.orig 2014-06-27 05:26:01 UTC
++++ libgphoto2_port/gphoto2/gphoto2-port-portability.h
+@@ -174,20 +174,6 @@ typedef struct {
/* yummy. :) */
diff --git a/graphics/libgphoto2/files/patch-libgphoto2_port__libusb1__libusb1.c b/graphics/libgphoto2/files/patch-libgphoto2_port__libusb1__libusb1.c
new file mode 100644
index 000000000000..d08896b6b39f
--- /dev/null
+++ b/graphics/libgphoto2/files/patch-libgphoto2_port__libusb1__libusb1.c
@@ -0,0 +1,13 @@
+--- libgphoto2_port/libusb1/libusb1.c.orig 2015-06-15 20:13:54 UTC
++++ libgphoto2_port/libusb1/libusb1.c
+@@ -66,6 +66,10 @@
+ }\
+ } while(0)
+
++#ifndef LIBUSB_CALL
++#define LIBUSB_CALL
++#endif
++
+ #ifndef HAVE_LIBUSB_STRERROR
+ static const char *libusb_strerror(int r)
+ {