aboutsummaryrefslogtreecommitdiff
path: root/graphics/libimg/Makefile
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1999-04-10 20:28:42 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1999-04-10 20:28:42 +0000
commit071479247d727f178082badc4eb5e435e691433c (patch)
treee39f51d78cde421b867015ee03a3b756cabc5d94 /graphics/libimg/Makefile
parent45529779c206bcf50a515af3160f29236a0f7887 (diff)
downloadports-071479247d727f178082badc4eb5e435e691433c.tar.gz
ports-071479247d727f178082badc4eb5e435e691433c.zip
Notes
Diffstat (limited to 'graphics/libimg/Makefile')
-rw-r--r--graphics/libimg/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/libimg/Makefile b/graphics/libimg/Makefile
new file mode 100644
index 000000000000..79fd6202a37f
--- /dev/null
+++ b/graphics/libimg/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: img
+# Version required: 1.1
+# Date Created: 20 February 1999
+# Whom: Glenn Johnson
+#
+# $Id$
+#
+
+DISTNAME= img1.1.4
+PKGNAME= libimg-1.1.4
+CATEGORIES= graphics tk80
+MASTER_SITES= ftp://ftp.neosoft.com/pub/tcl/sorted/packages-8.0/graphics/Img/1.1.4/
+
+MAINTAINER= gljohns@bellsouth.net
+
+LIB_DEPENDS= tk80.1:${PORTSDIR}/x11-toolkits/tk80 \
+ png.3:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff34
+
+WRKSRC= ${WRKDIR}/img1.1
+
+ALL_TARGET= default
+INSTALL_TARGET= install-base
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.0 --with-tk=${PREFIX}/lib/tk8.0
+
+post-install:
+ ${LN} -sf ${PREFIX}/lib/Img1.1/libimg1.1.so.1 ${PREFIX}/lib/libimg.so.1
+ ${LN} -sf ${PREFIX}/lib/libimg.so.1 ${PREFIX}/lib/libimg.so
+
+.include <bsd.port.mk>