aboutsummaryrefslogtreecommitdiff
path: root/graphics/libkdcraw/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2007-07-02 09:32:13 +0000
committerAlex Dupre <ale@FreeBSD.org>2007-07-02 09:32:13 +0000
commitd56fc4a4f9c599ba3e76787ec5318df9817e13a1 (patch)
tree68f673fe1971881cbc05e1cb232d5cf037562674 /graphics/libkdcraw/Makefile
parente486594704d6fa32cca7a6c49e96ace59dd2d942 (diff)
downloadports-d56fc4a4f9c599ba3e76787ec5318df9817e13a1.tar.gz
ports-d56fc4a4f9c599ba3e76787ec5318df9817e13a1.zip
Notes
Diffstat (limited to 'graphics/libkdcraw/Makefile')
-rw-r--r--graphics/libkdcraw/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/libkdcraw/Makefile b/graphics/libkdcraw/Makefile
new file mode 100644
index 000000000000..839faa1a96f4
--- /dev/null
+++ b/graphics/libkdcraw/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libkdcraw
+# Date created: 22 June 2007
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= libkdcraw
+PORTVERSION= 0.1.1
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kipi
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A C++ interface around a dcraw binary program
+
+LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+USE_GNOME= gnomehack pkgconfig
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g;s|-fno-schedule-insns -fno-inline||g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>