aboutsummaryrefslogtreecommitdiff
path: root/graphics/libkexif
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-11-17 16:48:26 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-11-17 16:48:26 +0000
commitcae1d33e56ee9bb19faaf4ee6e9e5d7670197857 (patch)
treeffe2ae95d078180bf54e9677718cfe9d8247470b /graphics/libkexif
parentbd646cbcd0e830a764710376dd93112e011cf228 (diff)
downloadports-cae1d33e56ee9bb19faaf4ee6e9e5d7670197857.tar.gz
ports-cae1d33e56ee9bb19faaf4ee6e9e5d7670197857.zip
Notes
Diffstat (limited to 'graphics/libkexif')
-rw-r--r--graphics/libkexif/Makefile29
-rw-r--r--graphics/libkexif/distinfo2
-rw-r--r--graphics/libkexif/pkg-descr10
-rw-r--r--graphics/libkexif/pkg-plist27
4 files changed, 68 insertions, 0 deletions
diff --git a/graphics/libkexif/Makefile b/graphics/libkexif/Makefile
new file mode 100644
index 000000000000..e34a42504fdc
--- /dev/null
+++ b/graphics/libkexif/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libkexif
+# Date created: Mon Oct 18 19:41:36 CEST 2004
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= libkexif
+PORTVERSION= 0.1
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= digikam
+
+MAINTAINER= avleeuwen@piwebs.com
+COMMENT= Library for manipulating EXIF information embedded in images
+
+LIB_DEPENDS= exif.10:${PORTSDIR}/graphics/libexif
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+USE_GNOME= gnomehack pkgconfig
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/graphics/libkexif/distinfo b/graphics/libkexif/distinfo
new file mode 100644
index 000000000000..ff5e20fc1cd2
--- /dev/null
+++ b/graphics/libkexif/distinfo
@@ -0,0 +1,2 @@
+MD5 (libkexif-0.1.tar.bz2) = 2d1ed6285fd9490c72327ff6dacd9185
+SIZE (libkexif-0.1.tar.bz2) = 472426
diff --git a/graphics/libkexif/pkg-descr b/graphics/libkexif/pkg-descr
new file mode 100644
index 000000000000..da39a7352b15
--- /dev/null
+++ b/graphics/libkexif/pkg-descr
@@ -0,0 +1,10 @@
+Libkexif is a library for manipulating EXIF information embedded in images.
+It currently supports viewing of all EXIF information via libexif. It also
+supports the modification of a few attributes in a safe way that preserves
+all other EXIF information in the file. It can currently modify the following
+tags:
+
+IFD0/Orientation
+EXIF/UserCommend
+
+WWW: http://digikam.sourceforge.net/
diff --git a/graphics/libkexif/pkg-plist b/graphics/libkexif/pkg-plist
new file mode 100644
index 000000000000..5bc784cf7045
--- /dev/null
+++ b/graphics/libkexif/pkg-plist
@@ -0,0 +1,27 @@
+include/libkexif/kexif.h
+include/libkexif/kexifdata.h
+include/libkexif/kexifentry.h
+include/libkexif/kexifutils.h
+lib/libkexif.la
+lib/libkexif.so
+lib/libkexif.so.0
+libdata/pkgconfig/libkexif.pc
+share/locale/br/LC_MESSAGES/libkexif.mo
+share/locale/ca/LC_MESSAGES/libkexif.mo
+share/locale/cy/LC_MESSAGES/libkexif.mo
+share/locale/da/LC_MESSAGES/libkexif.mo
+share/locale/de/LC_MESSAGES/libkexif.mo
+share/locale/en_GB/LC_MESSAGES/libkexif.mo
+share/locale/es/LC_MESSAGES/libkexif.mo
+share/locale/et/LC_MESSAGES/libkexif.mo
+share/locale/fr/LC_MESSAGES/libkexif.mo
+share/locale/ga/LC_MESSAGES/libkexif.mo
+share/locale/it/LC_MESSAGES/libkexif.mo
+share/locale/nl/LC_MESSAGES/libkexif.mo
+share/locale/pt/LC_MESSAGES/libkexif.mo
+share/locale/pt_BR/LC_MESSAGES/libkexif.mo
+share/locale/sr/LC_MESSAGES/libkexif.mo
+share/locale/sv/LC_MESSAGES/libkexif.mo
+share/locale/ta/LC_MESSAGES/libkexif.mo
+share/locale/tr/LC_MESSAGES/libkexif.mo
+@dirrm include/libkexif