aboutsummaryrefslogtreecommitdiff
path: root/graphics/liblqr-1/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-12 18:46:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-12 18:46:51 +0000
commit01343e96c902984c53f6ca8c7a445a36934fe1aa (patch)
tree77e67582556b2df8ddf4076e8d7b0d62e69e2eec /graphics/liblqr-1/Makefile
parent5b211eb2d4f39d4dd4eef04eb1d87c1e195d5a8a (diff)
downloadports-01343e96c902984c53f6ca8c7a445a36934fe1aa.tar.gz
ports-01343e96c902984c53f6ca8c7a445a36934fe1aa.zip
Notes
Diffstat (limited to 'graphics/liblqr-1/Makefile')
-rw-r--r--graphics/liblqr-1/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/graphics/liblqr-1/Makefile b/graphics/liblqr-1/Makefile
index f170490a9fd0..933ec48dfe2c 100644
--- a/graphics/liblqr-1/Makefile
+++ b/graphics/liblqr-1/Makefile
@@ -7,6 +7,7 @@
PORTNAME= liblqr-1
DISTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://liblqr.wdfiles.com/local--files/en:download-page/ \
http://mirror.amdmi3.ru/distfiles/
@@ -21,13 +22,6 @@ USE_GNOME= glib20 pkgconfig
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
- ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl \
- ${LOCALBASE}/share/xml/docbook/4.5/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml-450
-
-PORTDOCS= *
-.endif
.if !defined(NOPORTEXAMPLES)
PORTEXAMPLES= *
@@ -35,8 +29,18 @@ SUB_FILES= pkg-message
SUB_LIST= PORTSDIR=${PORTSDIR}
.endif
+OPTIONS= HTMLDOCS "Build and install HTML documentation" off
+
.include <bsd.port.pre.mk>
+.if defined(WITH_HTMLDOCS) && !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl \
+ ${LOCALBASE}/share/xml/docbook/4.5/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml-450
+
+PORTDOCS= *
+.endif
+
post-patch:
.if ${OSVERSION} < 700042
@${REINPLACE_CMD} -e 's|FVISIBILITY_FLAG=".*"|FVISIBILITY_FLAG=""|' ${WRKSRC}/configure
@@ -49,12 +53,12 @@ post-patch:
${WRKSRC}/docs/liblqr_manual.docbook
post-build:
-.if !defined(NOPORTDOCS)
+.if defined(WITH_HTMLDOCS) && !defined(NOPORTDOCS)
cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} ${MAKE} html
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if defined(WITH_HTMLDOCS) && !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/html/* ${DOCSDIR}
.endif