aboutsummaryrefslogtreecommitdiff
path: root/graphics/liblqr-1
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-17 09:59:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-17 09:59:56 +0000
commit826dbb8ea73551a53a1e7780b0774b4e6470395c (patch)
treec692d070b0ba7ba5b0f725cec3672a33890c88c5 /graphics/liblqr-1
parentb7d2b11733cdcd5f74128270d81af1ff8bbb2780 (diff)
downloadports-826dbb8ea73551a53a1e7780b0774b4e6470395c.tar.gz
ports-826dbb8ea73551a53a1e7780b0774b4e6470395c.zip
Notes
Diffstat (limited to 'graphics/liblqr-1')
-rw-r--r--graphics/liblqr-1/Makefile71
-rw-r--r--graphics/liblqr-1/distinfo3
-rw-r--r--graphics/liblqr-1/files/patch-examples-Makefile33
-rw-r--r--graphics/liblqr-1/pkg-descr19
-rw-r--r--graphics/liblqr-1/pkg-plist16
5 files changed, 142 insertions, 0 deletions
diff --git a/graphics/liblqr-1/Makefile b/graphics/liblqr-1/Makefile
new file mode 100644
index 000000000000..63d5d4269653
--- /dev/null
+++ b/graphics/liblqr-1/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: liblqr-1
+# Date created: 30 Jan 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liblqr-1
+DISTVERSION= 0.1.0-1
+CATEGORIES= graphics
+MASTER_SITES= http://liblqr.wikidot.com/local--files/en:download-page/ \
+ http://www.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= An easy to use C/C++ seam carving library
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 pkgconfig
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/^([0-9.]+)-([0-9]+)$/\1/}
+
+USE_LDCONFIG= yes
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl
+
+PORTDOCS= *
+.endif
+.if !defined(NOPORTEXAMPLES)
+PORTEXAMPLES= *
+
+PKGMESSAGE= ${WRKDIR}/pkg_message
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^lqr_pkgconfigdir/ s|$$(libdir)|$${exec_prefix}/libdata|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/usr.*chunk\.xsl|${LOCALBASE}/share/xsl/docbook/html/chunk.xsl|' \
+ ${WRKSRC}/docs/lqr_style.xsl
+
+post-build:
+.if !defined(NOPORTDOCS)
+ ${RM} ${WRKSRC}/examples/*.orig
+ cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} ${MAKE} xml
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/* ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+
+ @${ECHO_CMD} "==========================================================================" >> ${PKGMESSAGE}
+ @${ECHO_CMD} "NOTE: In order to compile examples for liblrq, you will" >> ${PKGMESSAGE}
+ @${ECHO_CMD} "also need pngwriter port (${PORTSDIR}/graphics/pngwriter)." >> ${PKGMESSAGE}
+ @${ECHO_CMD} "Examples are located in ${EXAMPLESDIR}" >> ${PKGMESSAGE}
+ @${ECHO_CMD} "==========================================================================" >> ${PKGMESSAGE}
+
+.if !exists(${LOCALBASE}/lib/libpngwriter.a)
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/liblqr-1/distinfo b/graphics/liblqr-1/distinfo
new file mode 100644
index 000000000000..df6c2b3acf9b
--- /dev/null
+++ b/graphics/liblqr-1/distinfo
@@ -0,0 +1,3 @@
+MD5 (liblqr-1-0.1.0-1.tar.gz) = 6c8be281b11b9782e45fa7f401e05087
+SHA256 (liblqr-1-0.1.0-1.tar.gz) = 55338d7dd7e50eec634535635e53c08151827074d99170eb3beda6ec15dec5e4
+SIZE (liblqr-1-0.1.0-1.tar.gz) = 367185
diff --git a/graphics/liblqr-1/files/patch-examples-Makefile b/graphics/liblqr-1/files/patch-examples-Makefile
new file mode 100644
index 000000000000..e617b827c068
--- /dev/null
+++ b/graphics/liblqr-1/files/patch-examples-Makefile
@@ -0,0 +1,33 @@
+--- examples/Makefile.orig 2007-12-21 18:02:50.000000000 +0300
++++ examples/Makefile 2008-01-30 05:43:08.000000000 +0300
+@@ -23,6 +23,8 @@
+
+
+ # collect flags for the compiler for lqr library
++CXX ?= g++
++
+ LQR_CFLAGS = `pkg-config --cflags lqr-1`
+
+ LQR_LIBS = `pkg-config --libs lqr-1`
+@@ -59,17 +61,17 @@
+
+ # linking
+ $(tt1out) : $(tt1obj)
+- g++ $(LINKING_FLAGS) -o $(tt1out) $(tt1obj)
++ $(CXX) $(tt1obj) $(LINKING_FLAGS) -o $(tt1out)
+
+ $(tt2out) : $(tt2obj)
+- g++ $(LINKING_FLAGS) -o $(tt2out) $(tt2obj)
++ $(CXX) $(tt2obj) $(LINKING_FLAGS) -o $(tt2out)
+
+ # object building
+ $(tt1).o : $(tt1).cpp $(tt1).h
+- g++ -c $(OBJ_BUILD_FLAGS) $(tt1).cpp
++ $(CXX) -c $(OBJ_BUILD_FLAGS) $(tt1).cpp
+
+ $(tt2).o : $(tt2).cpp
+- g++ -c $(OBJ_BUILD_FLAGS) $(tt2).cpp
++ $(CXX) -c $(OBJ_BUILD_FLAGS) $(tt2).cpp
+
+ #cleanup
+ clean:
diff --git a/graphics/liblqr-1/pkg-descr b/graphics/liblqr-1/pkg-descr
new file mode 100644
index 000000000000..4dcc19f2befa
--- /dev/null
+++ b/graphics/liblqr-1/pkg-descr
@@ -0,0 +1,19 @@
+This site is about a seam-carving C/C++ library called Liquid
+Rescale.
+
+It is a free, open source implementation of the algorithm described
+in the paper [1] by Shai Avidan and Ariel Shamir.
+
+It aims at resizing pictures non uniformly while preserving their
+features, i.e. avoiding distortion of the important parts.
+
+The API is intended to be powerful, yet fast and easy to use. It
+supports saving and loading of the carving information, real-time
+scaling, manual feature selection, customizable progress report and
+more.
+
+Included are full documentation (in docbook format) and examples.
+
+[1] http://www.faculty.idc.ac.il/arik/imret.pdf
+
+WWW: http://liblqr.wikidot.com/
diff --git a/graphics/liblqr-1/pkg-plist b/graphics/liblqr-1/pkg-plist
new file mode 100644
index 000000000000..240fd21f3176
--- /dev/null
+++ b/graphics/liblqr-1/pkg-plist
@@ -0,0 +1,16 @@
+include/lqr-1/lqr.h
+include/lqr-1/lqr/lqr_base.h
+include/lqr-1/lqr/lqr_carver_bias_pub.h
+include/lqr-1/lqr/lqr_carver_list_pub.h
+include/lqr-1/lqr/lqr_carver_pub.h
+include/lqr-1/lqr/lqr_cursor_pub.h
+include/lqr-1/lqr/lqr_gradient_pub.h
+include/lqr-1/lqr/lqr_progress_pub.h
+include/lqr-1/lqr/lqr_vmap_list_pub.h
+include/lqr-1/lqr/lqr_vmap_pub.h
+lib/liblqr-1.la
+lib/liblqr-1.so
+lib/liblqr-1.so.0
+libdata/pkgconfig/lqr-1.pc
+@dirrm include/lqr-1/lqr
+@dirrm include/lqr-1