aboutsummaryrefslogtreecommitdiff
path: root/graphics/libopenraw/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-03-21 19:23:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-03-21 19:23:36 +0000
commitbb945c1889a432d3ed452c5cd7735739d5a271f6 (patch)
tree3f1edd133dff3b4587c771915d5396fa6b6f3b31 /graphics/libopenraw/Makefile
parent2970fa7acde291a3de8bc8cfd869c80ee4051f0d (diff)
downloadports-bb945c1889a432d3ed452c5cd7735739d5a271f6.tar.gz
ports-bb945c1889a432d3ed452c5cd7735739d5a271f6.zip
Notes
Diffstat (limited to 'graphics/libopenraw/Makefile')
-rw-r--r--graphics/libopenraw/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/libopenraw/Makefile b/graphics/libopenraw/Makefile
new file mode 100644
index 000000000000..414aea32631c
--- /dev/null
+++ b/graphics/libopenraw/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: libopenraw
+# Date created: 21 Mar 2007
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopenraw
+PORTVERSION= 0.0.2
+CATEGORIES= graphics
+MASTER_SITES= http://libopenraw.freedesktop.org/download/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Library for camera RAW files decoding
+
+LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_GNOME= #
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= GNOME "GNOME support (needs gtk20)" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GNOME)
+USE_GNOME= gtk20
+PLIST_SUB+= GNOME=""
+.else
+CONFIGURE_ARGS+=--disable-gnome
+PLIST_SUB+= GNOME="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>