aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-05-21 19:30:54 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-05-21 19:30:54 +0000
commit943c52c8ccd51fa22033423130cb792b2a6c7083 (patch)
tree7954e3cb78911029ebb69dec626e64a28b5dd491 /graphics/libosmesa
parent049c1705f1c09d0d7e93924f6fced8765cba045d (diff)
downloadports-943c52c8ccd51fa22033423130cb792b2a6c7083.tar.gz
ports-943c52c8ccd51fa22033423130cb792b2a6c7083.zip
Update the Mesa ports to 17.1.0
* restrict use of LLVM for Gallium to platforms with LLVM in base to fix runtime errors when Gallium is built with a mix of GCC and LLVM * make LLVM only a BUILD_DEPEND for mesa-libs, which needs it to build EGL * add pkg-plist entries for freedreno and vc4 drivers [1] * remove extraneous SHEBANG_FILES entry to fix build of freedreno [2,3] * correct typo in libosmesa, which may have affected the Gallium build [4] PR: 219247 [1], 219406 [3] Submitted by: jbeich [1] (2 patches, pkg-plist fix), strejda (vc4 CFLAGS) Reported by: strejda [2], andrew [3], linimon [4] Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D10842
Notes
Notes: svn path=/head/; revision=441424
Diffstat (limited to 'graphics/libosmesa')
-rw-r--r--graphics/libosmesa/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index bc31ed35fec6..de324b088a60 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -7,20 +7,17 @@ CATEGORIES= graphics
COMMENT= Off-Screen Mesa implementation of the OpenGL API
-LIB_DEPENDS= libexpat.so:textproc/expat2 \
- libglapi.so:graphics/mesa-libs
-
USE_XORG= glproto
.include <bsd.port.options.mk>
-.include "${.CURDIR}/../../graphics/mesa-dri/Makefile.common"
+.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
CONFIGURE_ARGS+= --disable-dri --disable-egl --disable-gbm \
- --with-gallium-drivers=swrast
+ --disable-gles2 --with-gallium-drivers=swrast
MESA_BUILD_WRKSRC= src/util src/compiler src/mapi src/mesa
.if "${MESA_LLVM_VER}" != ""
-CONFGIURE_ARGS+= --enable-osmesa-gallium
+CONFIGURE_ARGS+= --enable-osmesa-gallium
MESA_BUILD_WRKSRC+= src/gallium
MESA_INSTALL_WRKSRC= src/gallium/state_trackers/osmesa src/gallium/targets/osmesa
.else
@@ -28,11 +25,11 @@ CONFIGURE_ARGS+= --enable-osmesa
MESA_INSTALL_WRKSRC= src/mesa/drivers/osmesa
.endif
-.include "${.CURDIR}/../../graphics/mesa-dri/Makefile.targets"
+.include "${MASTERDIR}/Makefile.targets"
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/GL
${INSTALL_DATA} ${WRKSRC}/include/GL/osmesa.h \
${STAGEDIR}${PREFIX}/include/GL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>