aboutsummaryrefslogtreecommitdiff
path: root/graphics/libpano13
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-18 20:32:47 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-18 20:32:47 +0000
commitd5b16182ecc3f02f68d5b8620071c8df15f0cd29 (patch)
tree567ef3b15071b8dfa52d293c005874f0cab2ec48 /graphics/libpano13
parent6620bb9bd57e4c8e1f2599517124a9578ab0a281 (diff)
downloadports-d5b16182ecc3f02f68d5b8620071c8df15f0cd29.tar.gz
ports-d5b16182ecc3f02f68d5b8620071c8df15f0cd29.zip
Notes
Diffstat (limited to 'graphics/libpano13')
-rw-r--r--graphics/libpano13/Makefile11
-rw-r--r--graphics/libpano13/files/patch-bootstrap92
2 files changed, 2 insertions, 101 deletions
diff --git a/graphics/libpano13/Makefile b/graphics/libpano13/Makefile
index 2788ef9943bf..75e76d5a4907 100644
--- a/graphics/libpano13/Makefile
+++ b/graphics/libpano13/Makefile
@@ -16,9 +16,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
USE_GNOME= gtk20 glib20 pango atk
-USES= libtool
-USE_AUTOTOOLS= autoconf:env autoheader:env aclocal:env \
- automake:env libtoolize
+USES= autoreconf libtool
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include/gtk-2.0 \
-I${LOCALBASE}/include/glib-2.0 \
@@ -27,6 +25,7 @@ CPPFLAGS+= -I${LOCALBASE}/include/gtk-2.0 \
CONFIGURE_ARGS= --with-png=${LOCALBASE} \
--with-jpeg=${LOCALBASE} \
--with-tiff=${LOCALBASE}
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
@@ -41,10 +40,4 @@ CONFIGURE_ARGS+= --without-java
PLIST_SUB= JAVA="@comment "
.endif
-pre-configure:
- cd ${WRKSRC} && ./bootstrap
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpano13.so.2
-
.include <bsd.port.mk>
diff --git a/graphics/libpano13/files/patch-bootstrap b/graphics/libpano13/files/patch-bootstrap
deleted file mode 100644
index 897ecfa0c0b8..000000000000
--- a/graphics/libpano13/files/patch-bootstrap
+++ /dev/null
@@ -1,92 +0,0 @@
---- bootstrap.orig 2011-02-22 11:06:38.000000000 -0800
-+++ bootstrap 2012-05-03 17:40:55.000000000 -0700
-@@ -18,63 +18,2 @@
-
--DIE=0
--
--have_libtool=false
--if $LIBTOOLIZE --version < /dev/null > /dev/null 2>&1 ; then
-- libtool_version=`$LIBTOOLIZE --version | sed 's/.*) \([0-9.][0-9.]*\).*/\1/'`
--# echo libtool version: $libtool_version
-- case $libtool_version in
-- 1.4*|1.5*|2.0*|2.2*|2.4*)
-- have_libtool=true
-- ;;
-- esac
--fi
--if $have_libtool ; then : ; else
-- echo
-- echo "You must have libtool 1.4 or later installed to compile $PROJECT."
-- echo "Install the appropriate package for your distribution,"
-- echo "or get the source tarball at http://ftp.gnu.org/gnu/libtool/"
-- DIE=1
--fi
--
--# Assume if we have this that aclocal and autoheader are available
--have_autoconf=false
--if $AUTOCONF --version < /dev/null > /dev/null 2>&1 ; then
-- autoconf_version=`$AUTOCONF --version | sed 's/^[^0-9]*\([0-9.][0-9.]*\).*/\1/'`
--# echo autoconf version: $autoconf_version
-- case $autoconf_version in
-- 2.5*|2.6*)
-- have_autoconf=true
-- ;;
-- esac
--fi
--if $have_autoconf ; then : ; else
-- echo
-- echo "You must have autoconf installed to compile $PROJECT."
-- echo "Install the appropriate package for your distribution,"
-- echo "or get the source tarball at http://ftp.gnu.org/gnu/autoconf/"
-- DIE=1
--fi
--
--have_automake=false
--if $AUTOMAKE --version < /dev/null > /dev/null 2>&1 ; then
-- automake_version=`$AUTOMAKE --version | sed 's/^[^0-9]*\([0-9.][0-9.]*\).*/\1/'`
--# echo automake version: $automake_version
-- case $automake_version in
-- 1.7*|1.8*|1.9*|1.10*|1.11*)
-- have_automake=true
-- ;;
-- esac
--fi
--if $have_automake ; then : ; else
-- echo
-- echo "You must have automake 1.7.x or later installed to compile $PROJECT."
-- echo "Install the appropriate package for your distribution,"
-- echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
-- DIE=1
--fi
--
--if test "$DIE" -eq 1; then
-- exit 1
--fi
--
- test $TEST_TYPE $FILE || {
-@@ -98,25 +37 @@
- $AUTOCONF || exit $?
--
--cd $ORIGDIR || exit $?
--
--echo
--echo "I am going to run ./configure with the following arguments:"
--echo
--echo " --enable-maintainer-mode $AUTOGEN_CONFIGURE_ARGS $@"
--echo
--
--if test -z "$*"; then
-- echo "If you wish to pass additional arguments, please specify them "
-- echo "on the $0 command line or set the AUTOGEN_CONFIGURE_ARGS "
-- echo "environment variable."
-- echo
--fi
--
--$srcdir/configure --enable-maintainer-mode $AUTOGEN_CONFIGURE_ARGS "$@"
--RC=$?
--if test $RC -ne 0; then
-- echo
-- echo "Configure failed or did not finish!"
-- exit $RC
--fi
--