aboutsummaryrefslogtreecommitdiff
path: root/graphics/libpgf/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-07-30 20:19:18 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-07-30 20:19:18 +0000
commit3b283a57f4be875805d2afa532dc2468ed962857 (patch)
treeb5f1f8bbfaded87cd2c63e8d1c296f965a105b43 /graphics/libpgf/Makefile
parentde8e4b4d20cee0594f96ae78450ddc9f144fe457 (diff)
Notes
Diffstat (limited to 'graphics/libpgf/Makefile')
-rw-r--r--graphics/libpgf/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/libpgf/Makefile b/graphics/libpgf/Makefile
new file mode 100644
index 000000000000..95585bfb5dee
--- /dev/null
+++ b/graphics/libpgf/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libpgf
+# Date Created: 2012-06-04
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpgf
+PORTVERSION= 6.12.24
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}-latest/ \
+ SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= Progressive Graphics Format (PGF) library
+
+LICENSE= LGPL21
+
+USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
+USE_LDCONFIG= yes
+
+LIBTOOLIZE_ARGS=--copy --force
+AUTOMAKE_ARGS= --add-missing --copy
+ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+pre-configure:
+ @cd ${WRKSRC}; ${TOUCH} NEWS AUTHORS
+
+.include <bsd.port.mk>