aboutsummaryrefslogtreecommitdiff
path: root/graphics/libqrencode
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2017-03-04 11:34:32 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2017-03-04 11:34:32 +0000
commitad7c0cf24abdd34eddfef98964e883a17b5b2832 (patch)
tree6be2c02dedecbcd2fff9ffbca2a0dd6abcecf310 /graphics/libqrencode
parent687d7460552ee782693da6949d4078aafdeeeea7 (diff)
downloadports-ad7c0cf24abdd34eddfef98964e883a17b5b2832.tar.gz
ports-ad7c0cf24abdd34eddfef98964e883a17b5b2832.zip
Notes
Diffstat (limited to 'graphics/libqrencode')
-rw-r--r--graphics/libqrencode/Makefile3
-rw-r--r--graphics/libqrencode/files/patch-CMakeLists.txt27
2 files changed, 30 insertions, 0 deletions
diff --git a/graphics/libqrencode/Makefile b/graphics/libqrencode/Makefile
index e01198c8b27a..bacf00eb7549 100644
--- a/graphics/libqrencode/Makefile
+++ b/graphics/libqrencode/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libqrencode
PORTVERSION= 3.9.0
+PORTREVISION= 1
CATEGORIES= graphics
DISTNAME= qrencode-${PORTVERSION}
@@ -26,6 +27,8 @@ CMAKE_ARGS= -DBUILD_SHARED_LIBS=ON
PLIST_FILES= bin/qrencode \
include/qrencode.h \
lib/libqrencode.so \
+ lib/libqrencode.so.3 \
+ lib/libqrencode.so.3.9.0 \
libdata/pkgconfig/libqrencode.pc \
man/man1/qrencode.1.gz
diff --git a/graphics/libqrencode/files/patch-CMakeLists.txt b/graphics/libqrencode/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..b1d5d2a954b4
--- /dev/null
+++ b/graphics/libqrencode/files/patch-CMakeLists.txt
@@ -0,0 +1,27 @@
+--- CMakeLists.txt.orig 2017-02-05 05:47:23 UTC
++++ CMakeLists.txt
+@@ -101,10 +101,17 @@ if(BUILD_SHARED_LIBS)
+ set(CMAKE_WINDOWS_EXPORT_ALL_SYMBOLS ON)
+ endif()
+ add_library(qrencode SHARED ${QRENCODE_SRCS} ${QRENCODE_HDRS})
++ set_target_properties(qrencode PROPERTIES VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH} SOVERSION ${PROJECT_VERSION_MAJOR})
+ else()
+ add_library(qrencode ${QRENCODE_SRCS} ${QRENCODE_HDRS})
+ endif()
+
++set(prefix "${CMAKE_INSTALL_PREFIX}")
++set(exec_prefix "${CMAKE_INSTALL_PREFIX}/bin")
++set(libdir "${CMAKE_INSTALL_PREFIX}/lib")
++set(includedir "${CMAKE_INSTALL_PREFIX}/include")
++set(VERSION "${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}")
++
+ configure_file(qrencode.1.in qrencode.1 @ONLY)
+ configure_file(libqrencode.pc.in libqrencode.pc @ONLY)
+
+@@ -166,4 +173,4 @@ message(STATUS " Project configuration:"
+ message(STATUS " .. Build test programs ........ = ${WITH_TESTS}" )
+ message(STATUS " .. Build utility tools ........ = ${WITH_TOOLS}" )
+ message(STATUS " .. Installation prefix ......... = ${CMAKE_INSTALL_PREFIX}" )
+-message(STATUS "------------------------------------------------------------ ")
+\ No newline at end of file
++message(STATUS "------------------------------------------------------------ ")