aboutsummaryrefslogtreecommitdiff
path: root/graphics/libraw/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2008-05-06 05:03:26 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2008-05-06 05:03:26 +0000
commit273a36732d26cdc9aa712564e119fae087e689e1 (patch)
treecf58c08e4f5ddbceb38e7f752b39c6546a2eed81 /graphics/libraw/Makefile
parent8ac1d2c1c379f9f01dcbc2bf65ce945abb9fc030 (diff)
Notes
Diffstat (limited to 'graphics/libraw/Makefile')
-rw-r--r--graphics/libraw/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/libraw/Makefile b/graphics/libraw/Makefile
new file mode 100644
index 000000000000..fb0c23180b7b
--- /dev/null
+++ b/graphics/libraw/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: raw images library
+# Date created: 26 Apr 2008
+# Whom: osa
+#
+# $FreeBSD$
+#
+
+PORTNAME= libraw
+PORTVERSION= 0.5.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.libraw.su/data/
+DISTNAME= LibRaw-${PORTVERSION}
+
+MAINTAINER= osa@FreeBSD.org
+COMMENT= Library for manipulating raw images
+
+MAKE_ENV+= CXX="${CXX}" CC="${CC}" CFLAGS="${CFLAGS}" \
+ PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
+
+USE_LDCONFIG= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/libraw
+
+.for f in libraw.h libraw_alloc.h libraw_const.h libraw_internal.h libraw_io.h libraw_types.h
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${f} ${PREFIX}/include/libraw
+.endfor
+.for f in libraw.a libraw.so.0 libraw_r.a libraw_r.so.0
+ @${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib
+.endfor
+.for f in libraw libraw_r
+ @ cd ${PREFIX}/lib ; ${LN} -sf ${f}.so.0 ${f}.so
+.endfor
+
+.include <bsd.port.mk>