aboutsummaryrefslogtreecommitdiff
path: root/graphics/librsvg/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-05-08 18:57:01 +0000
committerAde Lovett <ade@FreeBSD.org>2001-05-08 18:57:01 +0000
commitac510e8d2de18e0102375ad113b461f8b34deed8 (patch)
treec0fda6bb787b2594f832b4bc28c6b55f56a9367f /graphics/librsvg/Makefile
parent9025185d38d985f4a80e9c02eaaf9104526c0e06 (diff)
Notes
Diffstat (limited to 'graphics/librsvg/Makefile')
-rw-r--r--graphics/librsvg/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/librsvg/Makefile b/graphics/librsvg/Makefile
new file mode 100644
index 000000000000..c921e76dc539
--- /dev/null
+++ b/graphics/librsvg/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: librsvg
+# Date created: 8th May 2001
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= librsvg
+PORTVERSION= 1.0.0
+CATEGORIES= graphics gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= stable/sources/librsvg
+
+MAINTAINER= ade@FreeBSD.org
+
+BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
+LIB_DEPENDS= freetype.6:${PORTSDIR}/print/freetype2
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>