aboutsummaryrefslogtreecommitdiff
path: root/graphics/librsvg2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
commit9c0caae1c20155b432bb0feb074a8fd9cc1c12bc (patch)
tree534d0190982c831de589344c3003940ec6f2d6b1 /graphics/librsvg2/Makefile
parent27d17afba2c21f490ea8472d7aa37495e02e3ed8 (diff)
downloadports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.tar.gz
ports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.zip
Notes
Diffstat (limited to 'graphics/librsvg2/Makefile')
-rw-r--r--graphics/librsvg2/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index d3ba995acfbc..6e4dbb12d526 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= librsvg2
-PORTVERSION= 2.2.5
-PORTREVISION= 2
+PORTVERSION= 2.4.0
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
DISTNAME= librsvg-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,7 +18,8 @@ COMMENT= Library for parsing and rendering SVG vector-graphic files
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- popt.0:${PORTSDIR}/devel/popt
+ popt.0:${PORTSDIR}/devel/popt \
+ gsf-1.9:${PORTSDIR}/devel/libgsf
RUN_DEPENDS= ${X11BASE}/lib/gtk-2.0/2.2.0/engines/libmetal.so:${PORTSDIR}/x11-toolkits/gtk-engines2
USE_BZIP2= yes
@@ -28,9 +28,9 @@ USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack gtk20 libartlgpl2 libxml2 libgsf
+USE_GNOME= gnomehack gtk20 libartlgpl2 libxml2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-svgz \
--disable-gtk-doc
PLIST_SUB= GTK_VERSION="2.2.0"