aboutsummaryrefslogtreecommitdiff
path: root/graphics/librsvg2
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-02-01 16:39:16 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-02-01 16:39:16 +0000
commita73e8e0f7ceec25f8e3e25aa13405caca6e6ea6a (patch)
tree2f4d6bf1325390d697d3d349706dedbfb70ccde2 /graphics/librsvg2
parent699f9e581e1cafdbcceb36680c37e47a5c0e49f2 (diff)
downloadports-a73e8e0f7ceec25f8e3e25aa13405caca6e6ea6a.tar.gz
ports-a73e8e0f7ceec25f8e3e25aa13405caca6e6ea6a.zip
Notes
Diffstat (limited to 'graphics/librsvg2')
-rw-r--r--graphics/librsvg2/Makefile2
-rw-r--r--graphics/librsvg2/files/patch-cmdline-bugfixes29
2 files changed, 30 insertions, 1 deletions
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index df15602807d8..7cacb2360025 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -8,7 +8,7 @@
PORTNAME= librsvg2
PORTVERSION= 2.22.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/graphics/librsvg2/files/patch-cmdline-bugfixes b/graphics/librsvg2/files/patch-cmdline-bugfixes
new file mode 100644
index 000000000000..b70108aa3eb5
--- /dev/null
+++ b/graphics/librsvg2/files/patch-cmdline-bugfixes
@@ -0,0 +1,29 @@
+--- librsvg-2.22.2~/rsvg-convert.c 2007-07-01 23:43:44.000000000 +1000
++++ rsvg-convert.c 2008-10-20 16:52:27.000000000 +1100
+@@ -31,6 +31,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <locale.h>
+
+ #include "rsvg.h"
+ #include "rsvg-cairo.h"
+@@ -52,7 +53,7 @@
+ display_error (GError * err)
+ {
+ if (err) {
+- g_print ("%s", err->message);
++ g_print ("%s\n", err->message);
+ g_error_free (err);
+ }
+ }
+@@ -165,6 +166,9 @@
+ {NULL}
+ };
+
++ /* Set the locale so that UTF-8 filenames work */
++ setlocale(LC_ALL, "");
++
+ g_thread_init(NULL);
+
+ g_option_context = g_option_context_new (_("- SVG Converter"));