aboutsummaryrefslogtreecommitdiff
path: root/graphics/librsvg2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /graphics/librsvg2
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Notes
Diffstat (limited to 'graphics/librsvg2')
-rw-r--r--graphics/librsvg2/Makefile78
-rw-r--r--graphics/librsvg2/distinfo4
-rw-r--r--graphics/librsvg2/files/extra-patch-Makefile.in11
-rw-r--r--graphics/librsvg2/files/patch-configure17
-rw-r--r--graphics/librsvg2/files/patch-librsvg-2.0.pc.in9
-rw-r--r--graphics/librsvg2/files/patch-moz-plugin_Makefile.in27
-rw-r--r--graphics/librsvg2/files/patch-moz-plugin_moz-plugin.c15
-rw-r--r--graphics/librsvg2/pkg-plist21
8 files changed, 155 insertions, 27 deletions
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index 78d92c7d1607..1d534fa7dbc0 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= librsvg2
-PORTVERSION= 2.6.5
-PORTREVISION= 1
+PORTVERSION= 2.8.1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
DISTNAME= librsvg-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,23 +19,84 @@ COMMENT= Library for parsing and rendering SVG vector-graphic files
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
popt.0:${PORTSDIR}/devel/popt \
- croco.3:${PORTSDIR}/textproc/libcroco
-RUN_DEPENDS= ${X11BASE}/lib/gtk-2.0/2.4.0/engines/libmetal.so:${PORTSDIR}/x11-themes/gtk-engines2
+ croco-${CROCO_VERSION}.3:${PORTSDIR}/textproc/libcroco
+RUN_DEPENDS= ${X11BASE}/lib/gtk-2.0/${GTK_VERSION}/engines/libmetal.so:${PORTSDIR}/x11-themes/gtk-engines2
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=13
-USE_GNOME= gnomehack lthack gtk20 libartlgpl2 libxml2 libgsf
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomeprefix libartlgpl2 libgsf gnomevfs2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-svgz \
--disable-gtk-doc \
--without-gimp \
+ --enable-gnome-vfs \
--with-croco
-PLIST_SUB= GTK_VERSION="2.4.0"
+
+CROCO_VERSION= 0.6
+GTK_VERSION= 2.4.0
+
+PLIST_SUB= GTK_VERSION=${GTK_VERSION}
MAN1= rsvg.1
-.include <bsd.port.mk>
+OPTIONS= MOZILLA_PLUGIN "Enable the RSVG browser plug-in" no
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MOZILLA_PLUGIN)
+.if defined(WITH_MOZILLA) && ${WITH_MOZILLA}=="firefox"
+BUILD_DEPENDS+= ${X11BASE}/lib/firefox/lib/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
+RUN_DEPENDS+= ${X11BASE}/lib/firefox/lib/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
+.else
+BUILD_DEPENDS+= ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
+RUN_DEPENDS+= ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
+.endif
+
+HEADERS_SUFX=
+
+.if !defined(WITH_MOZILLA)
+HEADERS_SUFX=
+.else
+.if ${WITH_MOZILLA}=="mozilla"
+HEADERS_SUFX=
+.else
+.if ${WITH_MOZILLA}=="mozilla-devel"
+HEADERS_SUFX= -devel
+.else
+.if ${WITH_MOZILLA}=="firefox"
+CONFIGURE_ENV+= PKG_CONFIG_PATH=${X11BASE}/lib/firefox/lib/pkgconfig
+.endif
+.endif
+.endif
+.endif
+PLIST_SUB+= PLUGIN=""
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in
+PLIST_SUB+= PLUGIN="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/librsvg-2.0.pc.in
+.if defined(WITH_MOZILLA_PLUGIN)
+.if defined(WITH_MOZILLA) && ${WITH_MOZILLA}=="firefox"
+ @${REINPLACE_CMD} -e 's|mozilla-|firefox-|g' ${WRKSRC}/configure
+.else
+ @${REINPLACE_CMD} -e 's|mozilla-plugin|mozilla-plugin${HEADERS_SUFX}|g' \
+ ${WRKSRC}/configure
+.endif
+.endif
+
+.if defined(WITH_MOZILLA_PLUGIN)
+post-install:
+ ${MKDIR} ${PREFIX}/lib/browser_plugins
+ ${INSTALL_PROGRAM} ${WRKSRC}/moz-plugin/.libs/libmozsvgdec.so \
+ ${PREFIX}/lib/browser_plugins
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/librsvg2/distinfo b/graphics/librsvg2/distinfo
index 7e8e9281e375..567866d8a371 100644
--- a/graphics/librsvg2/distinfo
+++ b/graphics/librsvg2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/librsvg-2.6.5.tar.bz2) = 2d1d16f9493c80ce8214e585727334ae
-SIZE (gnome2/librsvg-2.6.5.tar.bz2) = 294229
+MD5 (gnome2/librsvg-2.8.1.tar.bz2) = 01c14f6adcf3a71be2b808879e1223a0
+SIZE (gnome2/librsvg-2.8.1.tar.bz2) = 361446
diff --git a/graphics/librsvg2/files/extra-patch-Makefile.in b/graphics/librsvg2/files/extra-patch-Makefile.in
new file mode 100644
index 000000000000..27c8fcd2988f
--- /dev/null
+++ b/graphics/librsvg2/files/extra-patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Sep 3 00:54:51 2004
++++ Makefile.in Fri Sep 3 00:55:00 2004
+@@ -307,7 +307,7 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-SUBDIRS = . gtk-engine gdk-pixbuf-loader moz-plugin doc data
++SUBDIRS = . gtk-engine gdk-pixbuf-loader doc data
+ @HAVE_GTK_FALSE@target_rsvg_view =
+ @HAVE_GTK_TRUE@target_rsvg_view = rsvg-view
+ man_MANS = rsvg.1
diff --git a/graphics/librsvg2/files/patch-configure b/graphics/librsvg2/files/patch-configure
index 087685258357..38c33bc6c06a 100644
--- a/graphics/librsvg2/files/patch-configure
+++ b/graphics/librsvg2/files/patch-configure
@@ -1,10 +1,11 @@
---- configure.orig Sat May 1 14:14:13 2004
-+++ configure Sat May 1 14:14:20 2004
-@@ -157,6 +157,7 @@
+--- configure.orig Wed Jun 9 01:30:07 2004
++++ configure Wed Jun 9 01:30:24 2004
+@@ -22052,7 +22052,7 @@
+ if test "x$with_html_dir" = "x" ; then
+ HTML_DIR='${datadir}/doc/librsvg/html'
+ else
+- HTML_DIR=$with_html_dir
++ HTML_DIR=${with_html_dir}/librsvg/html
+ fi
-
-+unset tagnames
- tagnames=${tagnames+${tagnames},}CXX
-
- tagnames=${tagnames+${tagnames},}F77
diff --git a/graphics/librsvg2/files/patch-librsvg-2.0.pc.in b/graphics/librsvg2/files/patch-librsvg-2.0.pc.in
new file mode 100644
index 000000000000..8210a432bc0d
--- /dev/null
+++ b/graphics/librsvg2/files/patch-librsvg-2.0.pc.in
@@ -0,0 +1,9 @@
+--- librsvg-2.0.pc.in.orig Fri Jun 4 20:23:35 2004
++++ librsvg-2.0.pc.in Wed Jun 9 01:58:50 2004
+@@ -7,5 +7,5 @@
+ Description: library that renders svg files
+ Version: @VERSION@
+ Requires: glib-2.0 gdk-pixbuf-2.0
+-Libs: -L${libdir} -lrsvg-2
++Libs: -L${libdir} -lrsvg-2 %%PTHREAD_LIBS%%
+ Cflags: -I${includedir}/librsvg-2
diff --git a/graphics/librsvg2/files/patch-moz-plugin_Makefile.in b/graphics/librsvg2/files/patch-moz-plugin_Makefile.in
new file mode 100644
index 000000000000..1f570b2472c2
--- /dev/null
+++ b/graphics/librsvg2/files/patch-moz-plugin_Makefile.in
@@ -0,0 +1,27 @@
+--- moz-plugin/Makefile.in.orig Fri Sep 3 01:07:24 2004
++++ moz-plugin/Makefile.in Fri Sep 3 01:08:00 2004
+@@ -282,15 +282,15 @@
+ $(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+ install-pluginLTLIBRARIES: $(plugin_LTLIBRARIES)
+- @$(NORMAL_INSTALL)
+- test -z "$(plugindir)" || $(mkdir_p) "$(DESTDIR)$(plugindir)"
+- @list='$(plugin_LTLIBRARIES)'; for p in $$list; do \
+- if test -f $$p; then \
+- f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(LIBTOOL) --mode=install $(pluginLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(plugindir)/$$f'"; \
+- $(LIBTOOL) --mode=install $(pluginLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(plugindir)/$$f"; \
+- else :; fi; \
+- done
++# @$(NORMAL_INSTALL)
++# test -z "$(plugindir)" || $(mkdir_p) "$(DESTDIR)$(plugindir)"
++# @list='$(plugin_LTLIBRARIES)'; for p in $$list; do \
++# if test -f $$p; then \
++# f="`echo $$p | sed -e 's|^.*/||'`"; \
++# echo " $(LIBTOOL) --mode=install $(pluginLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(plugindir)/$$f'"; \
++# $(LIBTOOL) --mode=install $(pluginLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(plugindir)/$$f"; \
++# else :; fi; \
++# done
+
+ uninstall-pluginLTLIBRARIES:
+ @$(NORMAL_UNINSTALL)
diff --git a/graphics/librsvg2/files/patch-moz-plugin_moz-plugin.c b/graphics/librsvg2/files/patch-moz-plugin_moz-plugin.c
new file mode 100644
index 000000000000..f75959a2a4ef
--- /dev/null
+++ b/graphics/librsvg2/files/patch-moz-plugin_moz-plugin.c
@@ -0,0 +1,15 @@
+--- moz-plugin/moz-plugin.c.orig Fri Sep 3 00:48:45 2004
++++ moz-plugin/moz-plugin.c Fri Sep 3 00:49:35 2004
+@@ -26,9 +26,12 @@
+ #include <config.h>
+
+ #include <stdio.h>
++#ifdef HAVE_STDINT_H
+ #include <stdint.h>
++#endif
+ #include <unistd.h>
+ #include <sys/wait.h>
++#include <signal.h>
+
+ #include <X11/Xlib.h>
+ #include <X11/Intrinsic.h>
diff --git a/graphics/librsvg2/pkg-plist b/graphics/librsvg2/pkg-plist
index a950255e54d5..ef193121ef5f 100644
--- a/graphics/librsvg2/pkg-plist
+++ b/graphics/librsvg2/pkg-plist
@@ -1,30 +1,35 @@
bin/rsvg
+bin/rsvg-view
include/librsvg-2/librsvg/librsvg-features.h
include/librsvg-2/librsvg/rsvg-gz.h
include/librsvg-2/librsvg/rsvg.h
+%%PLUGIN%%lib/browser_plugins/libmozsvgdec.so
lib/gtk-2.0/%%GTK_VERSION%%/engines/libsvg.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/svg_loader.so
lib/librsvg-2.a
lib/librsvg-2.so
-lib/librsvg-2.so.8
+lib/librsvg-2.so.10
libdata/pkgconfig/librsvg-2.0.pc
share/doc/librsvg/html/home.png
-share/doc/librsvg/html/i1073.html
share/doc/librsvg/html/index.html
share/doc/librsvg/html/index.sgml
+share/doc/librsvg/html/ix01.html
share/doc/librsvg/html/left.png
-share/doc/librsvg/html/r22.html
-share/doc/librsvg/html/r436.html
-share/doc/librsvg/html/r473.html
share/doc/librsvg/html/right.png
-share/doc/librsvg/html/rsvg-convenience-functions.html
-share/doc/librsvg/html/rsvg-core-api.html
-share/doc/librsvg/html/rsvg-creating-a-svgz-reader.html
+share/doc/librsvg/html/rn01.html
+share/doc/librsvg/html/rn02.html
+share/doc/librsvg/html/rn03.html
+share/doc/librsvg/html/rsvg-Convenience-Functions.html
+share/doc/librsvg/html/rsvg-Core-API.html
+share/doc/librsvg/html/rsvg-Creating-a-SVGZ-reader.html
+share/doc/librsvg/html/rsvg.devhelp
share/doc/librsvg/html/rsvg.html
share/doc/librsvg/html/up.png
+share/gnome/pixmaps/svg-viewer.svg
@dirrm share/doc/librsvg/html
@dirrm share/doc/librsvg
@dirrm include/librsvg-2/librsvg
@dirrm include/librsvg-2
@exec %D/bin/gdk-pixbuf-query-loaders > /dev/null 2>&1 && %D/bin/gdk-pixbuf-query-loaders > %D/etc/gtk-2.0/gdk-pixbuf.loaders 2>/dev/null || /usr/bin/true
@unexec %D/bin/gdk-pixbuf-query-loaders > /dev/null 2>&1 && %D/bin/gdk-pixbuf-query-loaders > %D/etc/gtk-2.0/gdk-pixbuf.loaders 2>/dev/null || /usr/bin/true
+%%PLUGIN%%@unexec rmdir %D/lib/browser_plugins 2>/dev/null || /usr/bin/true