aboutsummaryrefslogtreecommitdiff
path: root/graphics/libungif
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-11-16 15:21:45 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-11-16 15:21:45 +0000
commit8bf9cc019c480d172d1c3ff8e7f8aafde45f439c (patch)
tree89556b2745c9978b00087348bb91e663a8454402 /graphics/libungif
parent00936b889df464bd44a5a24132ceb3931d5588cd (diff)
downloadports-8bf9cc019c480d172d1c3ff8e7f8aafde45f439c.tar.gz
ports-8bf9cc019c480d172d1c3ff8e7f8aafde45f439c.zip
Notes
Diffstat (limited to 'graphics/libungif')
-rw-r--r--graphics/libungif/Makefile2
-rw-r--r--graphics/libungif/files/patch-util_giftext.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/graphics/libungif/Makefile b/graphics/libungif/Makefile
index 60013d68bbe4..b7afbf883232 100644
--- a/graphics/libungif/Makefile
+++ b/graphics/libungif/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libungif
PORTVERSION= 4.1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/libungif/files/patch-util_giftext.c b/graphics/libungif/files/patch-util_giftext.c
new file mode 100644
index 000000000000..6227d274d74f
--- /dev/null
+++ b/graphics/libungif/files/patch-util_giftext.c
@@ -0,0 +1,9 @@
+--- util/giftext.c.orig Mon Oct 10 08:08:51 2005
++++ util/giftext.c Mon Aug 28 17:01:18 2006
+@@ -136,5 +136,5 @@
+ printf("\tColorResolution = %d, BitsPerPixel = %d, BackGround = %d.\n",
+ GifFile->SColorResolution,
+- GifFile->SColorMap->BitsPerPixel,
++ GifFile->SColorMap?GifFile->SColorMap->BitsPerPixel:0,
+ GifFile->SBackGroundColor);
+ if (GifFile->SColorMap)