aboutsummaryrefslogtreecommitdiff
path: root/graphics/libwpg/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:08:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:08:50 +0000
commit2fd93831f0c89d274608f0c97917178305840a1c (patch)
treec8e8f650ba833ec30586c0c951684b38939a0a1c /graphics/libwpg/Makefile
parent84648ccfcd9d5e50ed3608168097f032e80e76d3 (diff)
downloadports-2fd93831f0c89d274608f0c97917178305840a1c.tar.gz
ports-2fd93831f0c89d274608f0c97917178305840a1c.zip
Notes
Diffstat (limited to 'graphics/libwpg/Makefile')
-rw-r--r--graphics/libwpg/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/libwpg/Makefile b/graphics/libwpg/Makefile
new file mode 100644
index 000000000000..a349f76cb5a4
--- /dev/null
+++ b/graphics/libwpg/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: graphics/libwpg
+# Date created: 2009-01-09
+# Whom: Dima Panov <fluffy@Fluffy.Khv.RU>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libwpg
+PORTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= fluffy@Fluffy.Khv.RU
+COMMENT= Library for importing and converting Corel WordPerfect(tm) Graphics images
+
+LIB_DEPENDS= wpd-0.8.8:${PORTSDIR}/textproc/libwpd
+
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomeprefix gnomehack ltverhack
+USE_PERL5= yes
+USE_LDCONFIG= yes
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+DOCSDIR= ${LOCALBASE}/share/doc/${PORTNAME}-${PORTVERSION}
+.else
+post-patch:
+ @${REINPLACE_CMD} -E '/^SUBDIRS = /s/docs//g' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>