aboutsummaryrefslogtreecommitdiff
path: root/graphics/libwpg
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2013-04-22 18:47:52 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2013-04-22 18:47:52 +0000
commit624a325bdf46007856fa45ac2246b686665bc641 (patch)
tree466707f5b1a71b538aae7ecaf32b3e31b250c8b0 /graphics/libwpg
parent3156cdf2e14bf7e5b67b6609321eb2439043d4ae (diff)
downloadports-624a325bdf46007856fa45ac2246b686665bc641.tar.gz
ports-624a325bdf46007856fa45ac2246b686665bc641.zip
Notes
Diffstat (limited to 'graphics/libwpg')
-rw-r--r--graphics/libwpg/Makefile14
-rw-r--r--graphics/libwpg/distinfo4
-rw-r--r--graphics/libwpg/files/patch-src-lib-WPG2Parser.cpp38
3 files changed, 6 insertions, 50 deletions
diff --git a/graphics/libwpg/Makefile b/graphics/libwpg/Makefile
index 940a1a8c27ca..cc506bb134e2 100644
--- a/graphics/libwpg/Makefile
+++ b/graphics/libwpg/Makefile
@@ -1,20 +1,15 @@
-# New ports collection makefile for: graphics/libwpg
-# Date created: 2009-01-09
-# Whom: Dima Panov <fluffy@Fluffy.Khv.RU>
-#
# $FreeBSD$
-#
PORTNAME= libwpg
-PORTVERSION= 0.2.1
-PORTREVISION= 2
+PORTVERSION= 0.2.2
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Library and tools to work with WordPerfect Graphics (WPG) files
-LICENSE= LGPL20
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
LIB_DEPENDS= wpd-0.9:${PORTSDIR}/textproc/libwpd
@@ -28,12 +23,11 @@ CONFIGURE_ARGS= --disable-werror
OPTIONS_DEFINE= DOCS
-PORTDOCS= *
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+PORTDOCS= *
.else
post-patch:
@${REINPLACE_CMD} -E '/^SUBDIRS = /s/docs//g' ${WRKSRC}/Makefile.in
diff --git a/graphics/libwpg/distinfo b/graphics/libwpg/distinfo
index 727602587451..627f548bf668 100644
--- a/graphics/libwpg/distinfo
+++ b/graphics/libwpg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libwpg-0.2.1.tar.bz2) = a0bc8854af5affbcf6f91731d867163b96c4991220f8e3b28b9d49ca3cfba169
-SIZE (libwpg-0.2.1.tar.bz2) = 335521
+SHA256 (libwpg-0.2.2.tar.bz2) = ccb8907bdd78e2a094204a745431d6bcfdba475354ed3caba36aaea6c9d88626
+SIZE (libwpg-0.2.2.tar.bz2) = 376802
diff --git a/graphics/libwpg/files/patch-src-lib-WPG2Parser.cpp b/graphics/libwpg/files/patch-src-lib-WPG2Parser.cpp
deleted file mode 100644
index 0c7a88771479..000000000000
--- a/graphics/libwpg/files/patch-src-lib-WPG2Parser.cpp
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/lib/WPG2Parser.cpp
-+++ src/lib/WPG2Parser.cpp
-@@ -820,7 +820,7 @@ void WPG2Parser::handleDPPenForeColor()
- unsigned char red = (m_doublePrecision) ? readU16()>>8 : readU8();
- unsigned char green = (m_doublePrecision) ? readU16()>>8 : readU8();
- unsigned char blue = (m_doublePrecision) ? readU16()>>8 : readU8();
-- unsigned char alpha = 0xff - (m_doublePrecision) ? readU16()>>8 : readU8();
-+ unsigned char alpha = 0xff - ((m_doublePrecision) ? readU16()>>8 : readU8());
-
- m_style.insert("svg:stroke-color", libwpg::WPGColor(red, green, blue, alpha).getColorString());
- m_style.insert("svg:stroke-opacity", libwpg::WPGColor(red, green, blue, alpha).getOpacity(), WPX_PERCENT);
-@@ -860,7 +860,7 @@ void WPG2Parser::handleDPPenBackColor()
- unsigned int red = (m_doublePrecision) ? readU16()>>8 : readU8();
- unsigned int green = (m_doublePrecision) ? readU16()>>8 : readU8();
- unsigned int blue = (m_doublePrecision) ? readU16()>>8 : readU8();
-- unsigned int alpha = 0xff - (m_doublePrecision) ? readU16()>>8 : readU8();
-+ unsigned int alpha = 0xff - ((m_doublePrecision) ? readU16()>>8 : readU8());
-
- m_penBackColor = libwpg::WPGColor(red, green, blue, alpha);
-
-@@ -1156,7 +1156,7 @@ void WPG2Parser::handleDPBrushForeColor()
- unsigned char red = (m_doublePrecision) ? readU16()>>8 : readU8();
- unsigned char green = (m_doublePrecision) ? readU16()>>8 : readU8();
- unsigned char blue = (m_doublePrecision) ? readU16()>>8 : readU8();
-- unsigned char alpha = 0xff - (m_doublePrecision) ? readU16()>>8 : readU8();
-+ unsigned char alpha = 0xff - ((m_doublePrecision) ? readU16()>>8 : readU8());
- WPG_DEBUG_MSG((" Foreground color (RGBA): %d %d %d %d\n", red, green, blue, alpha));
-
- m_brushForeColor = libwpg::WPGColor(red, green, blue, alpha);
-@@ -1181,7 +1181,7 @@ void WPG2Parser::handleDPBrushForeColor()
- unsigned char red = (m_doublePrecision) ? readU16()>>8 : readU8();
- unsigned char green = (m_doublePrecision) ? readU16()>>8 : readU8();
- unsigned char blue = (m_doublePrecision) ? readU16()>>8 : readU8();
-- unsigned char alpha = 0xff - (m_doublePrecision) ? readU16()>>8 : readU8();
-+ unsigned char alpha = 0xff - ((m_doublePrecision) ? readU16()>>8 : readU8());
- libwpg::WPGColor color(red, green, blue, alpha);
- colors.push_back(color);
- WPG_DEBUG_MSG((" Color #%d (RGBA): %d %d %d %d\n", i+1, red, green, blue, alpha));