aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-ac3d/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-30 11:16:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-30 11:16:49 +0000
commit3a36c5b3da47b1e82967d4e9bf3cb18eec994def (patch)
tree34bf26aae5a5a0263fcc8f366ca829bf8078dcd5 /graphics/linux-ac3d/Makefile
parent4314b31c36cccfcaca4d76dc351f199a620f2152 (diff)
downloadports-3a36c5b3da47b1e82967d4e9bf3cb18eec994def.tar.gz
ports-3a36c5b3da47b1e82967d4e9bf3cb18eec994def.zip
Notes
Diffstat (limited to 'graphics/linux-ac3d/Makefile')
-rw-r--r--graphics/linux-ac3d/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/graphics/linux-ac3d/Makefile b/graphics/linux-ac3d/Makefile
index 7307f122ce57..5efe2424aaa2 100644
--- a/graphics/linux-ac3d/Makefile
+++ b/graphics/linux-ac3d/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= ac3d
-PORTVERSION= 4.0a
+PORTVERSION= 4.0f
CATEGORIES= graphics linux
MASTER_SITES= http://inivis.swmirror.com/
PKGNAMEPREFIX= linux-
-DISTNAME= ac3dlx${PORTVERSION:R}
+DISTNAME= ${PORTNAME}lx${PORTVERSION:R}
EXTRACT_SUFX= .tgz
MAINTAINER= tiamat@comset.net
@@ -23,7 +23,7 @@ LIB_DEPENDS= ${LINUXBASE}/usr/X11R6/libGLU.so.1:${PORTSDIR}/graphics/linux_mesa3
USE_LINUX= yes
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
-WRKSRC= ${WRKDIR}/ac3dlx
+WRKSRC= ${WRKDIR}/${PORTNAME}lx
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -51,9 +51,10 @@ pre-everything::
.endif
post-patch:
- @${CAT} pkg-message | ${SED} -e 's|%%PORTNAME%%|${PORTNAME}|; \
- s|%%PREFIX%%|${PREFIX}|; \
- s|%%EXAMPLESDIR%%|${EXAMPLESDIR}|' > ${PKGMESSAGE}
+ @${CAT} pkg-message | \
+ ${SED} -e 's|%%PORTNAME%%|${PORTNAME}|; \
+ s|%%PREFIX%%|${PREFIX}|; \
+ s|%%EXAMPLESDIR%%|${EXAMPLESDIR}|' > ${PKGMESSAGE}
pre-install:
# Generate startup script
@@ -83,6 +84,12 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/lib/tk8.4/*.tcl ${DATADIR}/lib/tk8.4
@${MKDIR} ${DATADIR}/tcl
@${INSTALL_DATA} ${WRKSRC}/tcl/*.tcl ${DATADIR}/tcl
+
+# fonts
+.for i in font fontwire
+ ${INSTALL_DATA} ${WRKSRC}/${i}.ac ${DATADIR}
+.endfor
+
.ifndef (NOPORTDOCS)
# docs
@${MKDIR} ${DOCSDIR}