aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-ac3d
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-09-01 17:44:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-09-01 17:44:14 +0000
commit2a65c3253e535cc0daf1abce0b03b77394bf416f (patch)
treef419fcdbf3b1e886872c90e1378d9afbe378ec4c /graphics/linux-ac3d
parent63b97201d0864c5e408d091f31524c79f0be0941 (diff)
downloadports-2a65c3253e535cc0daf1abce0b03b77394bf416f.tar.gz
ports-2a65c3253e535cc0daf1abce0b03b77394bf416f.zip
Notes
Diffstat (limited to 'graphics/linux-ac3d')
-rw-r--r--graphics/linux-ac3d/Makefile19
-rw-r--r--graphics/linux-ac3d/distinfo6
-rw-r--r--graphics/linux-ac3d/files/ac3ds.in5
-rw-r--r--graphics/linux-ac3d/pkg-descr4
-rw-r--r--graphics/linux-ac3d/pkg-plist268
5 files changed, 174 insertions, 128 deletions
diff --git a/graphics/linux-ac3d/Makefile b/graphics/linux-ac3d/Makefile
index 0d39af3229d3..1ef74b32a308 100644
--- a/graphics/linux-ac3d/Makefile
+++ b/graphics/linux-ac3d/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= ac3d
-PORTVERSION= 6.0
+PORTVERSION= 6.030
CATEGORIES= graphics linux
MASTER_SITES= http://www.ac3d.org/ac3d/download/release6/
PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}lx${PORTVERSION:R}
+DISTNAME= ${PORTNAME}lx${PORTVERSION:R}${PORTVERSION:E}
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hernan.di.pietro@gmail.com
COMMENT= Easy to use and powerful 3D graphics modeller (trial version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
@@ -27,17 +27,19 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
RESTRICTED= no distribution permitted
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}lx
-SUB_FILES= ac3d
+SUB_FILES= ac3d ac3ds
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ac3d ${PREFIX}/libexec
${INSTALL_SCRIPT} ${WRKDIR}/ac3d ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ac3ds ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKDIR}/ac3ds ${PREFIX}/bin
# Install small Tcl/Tk distribution
# Tcl/Tk, installed from ports tree will also make a job,
@@ -52,10 +54,17 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/lib/tk8.4/tclIndex ${DATADIR}/lib/tk8.4
${INSTALL_DATA} ${WRKSRC}/lib/tk8.4/*.tcl ${DATADIR}/lib/tk8.4
${MKDIR} ${DATADIR}/tcl
+
.for i in tcl xbm
${INSTALL_DATA} ${WRKSRC}/tcl/*.${i} ${DATADIR}/tcl
.endfor
+#images
+ ${MKDIR} ${DATADIR}/tcl/images
+.for i in gif
+ ${INSTALL_DATA} ${WRKSRC}/tcl/images/*.${i} ${DATADIR}/tcl/images
+.endfor
+
# fonts
.for i in font fontwire
${INSTALL_DATA} ${WRKSRC}/${i}.ac ${DATADIR}
diff --git a/graphics/linux-ac3d/distinfo b/graphics/linux-ac3d/distinfo
index 0bc2d8169016..4f7758415dce 100644
--- a/graphics/linux-ac3d/distinfo
+++ b/graphics/linux-ac3d/distinfo
@@ -1,3 +1,3 @@
-MD5 (ac3dlx6.tgz) = c91e64026f65bd0dbfb805fccd8c1eb4
-SHA256 (ac3dlx6.tgz) = b084c39b468dcc4766b9ade01b680ae893a1c1cb1e0928695d23e0e6cf5a2fa9
-SIZE (ac3dlx6.tgz) = 5436877
+MD5 (ac3dlx6030.tgz) = ced51d262a58ef69b645c474a6086b92
+SHA256 (ac3dlx6030.tgz) = 0bc179b1b0077ecfd4500f89b23b6fbe1f509abf8b982e2d03ce3a0e855ad9f5
+SIZE (ac3dlx6030.tgz) = 5494448
diff --git a/graphics/linux-ac3d/files/ac3ds.in b/graphics/linux-ac3d/files/ac3ds.in
new file mode 100644
index 000000000000..0020b97c343f
--- /dev/null
+++ b/graphics/linux-ac3d/files/ac3ds.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+export AC3D_HOME="%%DATADIR%%"
+
+exec %%PREFIX%%/libexec/ac3ds "$@"
diff --git a/graphics/linux-ac3d/pkg-descr b/graphics/linux-ac3d/pkg-descr
index 8967466e30d7..c08553735111 100644
--- a/graphics/linux-ac3d/pkg-descr
+++ b/graphics/linux-ac3d/pkg-descr
@@ -5,5 +5,5 @@ Dive, Massive and other formats.
WWW: http://www.ac3d.org/
-- Igor Pokrovsky
-tiamat@comset.net
+- Hernan Di Pietro
+hernan.di.pietro@gmail.com
diff --git a/graphics/linux-ac3d/pkg-plist b/graphics/linux-ac3d/pkg-plist
index 9c6aadd12fe3..1acb0fd9886a 100644
--- a/graphics/linux-ac3d/pkg-plist
+++ b/graphics/linux-ac3d/pkg-plist
@@ -1,123 +1,14 @@
bin/ac3d
+bin/ac3ds
libexec/ac3d
-%%DATADIR%%/font.ac
-%%DATADIR%%/fontwire.ac
-%%DATADIR%%/lib/tcl8.4/auto.tcl
-%%DATADIR%%/lib/tcl8.4/history.tcl
-%%DATADIR%%/lib/tcl8.4/init.tcl
-%%DATADIR%%/lib/tcl8.4/ldAout.tcl
-%%DATADIR%%/lib/tcl8.4/package.tcl
-%%DATADIR%%/lib/tcl8.4/parray.tcl
-%%DATADIR%%/lib/tcl8.4/safe.tcl
-%%DATADIR%%/lib/tcl8.4/tclIndex
-%%DATADIR%%/lib/tcl8.4/word.tcl
-%%DATADIR%%/lib/tk8.4/bgerror.tcl
-%%DATADIR%%/lib/tk8.4/button.tcl
-%%DATADIR%%/lib/tk8.4/choosedir.tcl
-%%DATADIR%%/lib/tk8.4/clrpick.tcl
-%%DATADIR%%/lib/tk8.4/comdlg.tcl
-%%DATADIR%%/lib/tk8.4/console.tcl
-%%DATADIR%%/lib/tk8.4/dialog.tcl
-%%DATADIR%%/lib/tk8.4/entry.tcl
-%%DATADIR%%/lib/tk8.4/focus.tcl
-%%DATADIR%%/lib/tk8.4/listbox.tcl
-%%DATADIR%%/lib/tk8.4/menu.tcl
-%%DATADIR%%/lib/tk8.4/mkpsenc.tcl
-%%DATADIR%%/lib/tk8.4/msgbox.tcl
-%%DATADIR%%/lib/tk8.4/obsolete.tcl
-%%DATADIR%%/lib/tk8.4/optMenu.tcl
-%%DATADIR%%/lib/tk8.4/palette.tcl
-%%DATADIR%%/lib/tk8.4/panedwindow.tcl
-%%DATADIR%%/lib/tk8.4/pkgIndex.tcl
-%%DATADIR%%/lib/tk8.4/safetk.tcl
-%%DATADIR%%/lib/tk8.4/scale.tcl
-%%DATADIR%%/lib/tk8.4/scrlbar.tcl
-%%DATADIR%%/lib/tk8.4/spinbox.tcl
-%%DATADIR%%/lib/tk8.4/tclIndex
-%%DATADIR%%/lib/tk8.4/tearoff.tcl
-%%DATADIR%%/lib/tk8.4/text.tcl
-%%DATADIR%%/lib/tk8.4/tk.tcl
-%%DATADIR%%/lib/tk8.4/tkfbox.tcl
-%%DATADIR%%/lib/tk8.4/unsupported.tcl
-%%DATADIR%%/lib/tk8.4/xmfbox.tcl
-%%DATADIR%%/plugins/DirectX.p
-%%DATADIR%%/plugins/DirectX.tcl
-%%DATADIR%%/plugins/LDraw.p
-%%DATADIR%%/plugins/LDraw.tcl
-%%DATADIR%%/plugins/airfoil_import.p
-%%DATADIR%%/plugins/centre.p
-%%DATADIR%%/plugins/centre.tcl
-%%DATADIR%%/plugins/csg.p
-%%DATADIR%%/plugins/csg.tcl
-%%DATADIR%%/plugins/ddsload.p
-%%DATADIR%%/plugins/dxf_export.p
-%%DATADIR%%/plugins/field_import.p
-%%DATADIR%%/plugins/font3d.tcl
-%%DATADIR%%/plugins/jpegload.p
-%%DATADIR%%/plugins/knife.p
-%%DATADIR%%/plugins/knife.tcl
-%%DATADIR%%/plugins/linecom.p
-%%DATADIR%%/plugins/lwexport.p
-%%DATADIR%%/plugins/lwimport.p
-%%DATADIR%%/plugins/milkshape_export.p
-%%DATADIR%%/plugins/milkshape_import.p
-%%DATADIR%%/plugins/obj_export.p
-%%DATADIR%%/plugins/obj_import.p
-%%DATADIR%%/plugins/off_import.p
-%%DATADIR%%/plugins/plantex.p
-%%DATADIR%%/plugins/plantex.tcl
-%%DATADIR%%/plugins/pngload.p
-%%DATADIR%%/plugins/point_import.p
-%%DATADIR%%/plugins/polymaker.tcl
-%%DATADIR%%/plugins/ppmload.p
-%%DATADIR%%/plugins/quakemap_export.p
-%%DATADIR%%/plugins/savepng.p
-%%DATADIR%%/plugins/smf_export.p
-%%DATADIR%%/plugins/smf_import.p
-%%DATADIR%%/plugins/stl_import.p
-%%DATADIR%%/plugins/t3d_export.p
-%%DATADIR%%/plugins/tgaload.p
-%%DATADIR%%/plugins/tiffload.p
-%%DATADIR%%/plugins/xdx_export.tcl
-%%DATADIR%%/tcl/ac3d.tcl
-%%DATADIR%%/tcl/ac3dfsbox.tcl
-%%DATADIR%%/tcl/ac3dhier.tcl
-%%DATADIR%%/tcl/ac3dkeys.tcl
-%%DATADIR%%/tcl/ac3dobject.tcl
-%%DATADIR%%/tcl/ac3dobjlib.tcl
-%%DATADIR%%/tcl/ac3dops.tcl
-%%DATADIR%%/tcl/ac3dpalette.tcl
-%%DATADIR%%/tcl/ac3dplugins.tcl
-%%DATADIR%%/tcl/ac3dprefs.tcl
-%%DATADIR%%/tcl/ac3drender.tcl
-%%DATADIR%%/tcl/ac3dtips.tcl
-%%DATADIR%%/tcl/ac3dttfont.tcl
-%%DATADIR%%/tcl/ac3dutil.tcl
-%%DATADIR%%/tcl/ac3duvedit.tcl
-%%DATADIR%%/tcl/ac3dview.tcl
-%%DATADIR%%/tcl/clean.xbm
-%%DATADIR%%/tcl/combobox.tcl
-%%DATADIR%%/tcl/inspect.xbm
-%%DATADIR%%/tcl/maxmin.xbm
-%%DATADIR%%/tcl/pan.xbm
-%%DATADIR%%/tcl/spin.xbm
-%%DATADIR%%/tcl/tick.xbm
-%%DATADIR%%/tcl/tickempty.xbm
-%%DATADIR%%/tcl/tilt.xbm
-%%DATADIR%%/tcl/toolbar.tcl
-%%DATADIR%%/tcl/viewall.xbm
-%%DATADIR%%/tcl/viewbottomleft.xbm
-%%DATADIR%%/tcl/viewbottomright.xbm
-%%DATADIR%%/tcl/viewtopleft.xbm
-%%DATADIR%%/tcl/viewtopright.xbm
-%%DATADIR%%/tcl/walk.xbm
-%%DATADIR%%/tcl/zoom.xbm
-%%PORTDOCS%%%%DOCSDIR%%/IMPORTANT
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+libexec/ac3ds
%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/IMPORTANT
%%PORTDOCS%%%%DOCSDIR%%/manual/left.html
%%PORTDOCS%%%%DOCSDIR%%/manual/man.html
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image001.gif
+%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image036.gif
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image002.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image003.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image004.jpg
@@ -152,7 +43,6 @@ libexec/ac3d
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image033.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image034.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image035.jpg
-%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image036.gif
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image037.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image038.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/man_files/image039.jpg
@@ -343,14 +233,156 @@ libexec/ac3d
%%EXAMPLESDIR%%/tree_transparent.gif
%%EXAMPLESDIR%%/world.ac
%%EXAMPLESDIR%%/world.rgb
-@dirrm %%EXAMPLESDIR%%
+%%DATADIR%%/lib/tcl8.4/tclIndex
+%%DATADIR%%/lib/tcl8.4/auto.tcl
+%%DATADIR%%/lib/tcl8.4/history.tcl
+%%DATADIR%%/lib/tcl8.4/init.tcl
+%%DATADIR%%/lib/tcl8.4/ldAout.tcl
+%%DATADIR%%/lib/tcl8.4/package.tcl
+%%DATADIR%%/lib/tcl8.4/parray.tcl
+%%DATADIR%%/lib/tcl8.4/safe.tcl
+%%DATADIR%%/lib/tcl8.4/word.tcl
+%%DATADIR%%/lib/tk8.4/tclIndex
+%%DATADIR%%/lib/tk8.4/bgerror.tcl
+%%DATADIR%%/lib/tk8.4/button.tcl
+%%DATADIR%%/lib/tk8.4/choosedir.tcl
+%%DATADIR%%/lib/tk8.4/clrpick.tcl
+%%DATADIR%%/lib/tk8.4/comdlg.tcl
+%%DATADIR%%/lib/tk8.4/console.tcl
+%%DATADIR%%/lib/tk8.4/dialog.tcl
+%%DATADIR%%/lib/tk8.4/entry.tcl
+%%DATADIR%%/lib/tk8.4/focus.tcl
+%%DATADIR%%/lib/tk8.4/listbox.tcl
+%%DATADIR%%/lib/tk8.4/menu.tcl
+%%DATADIR%%/lib/tk8.4/mkpsenc.tcl
+%%DATADIR%%/lib/tk8.4/msgbox.tcl
+%%DATADIR%%/lib/tk8.4/obsolete.tcl
+%%DATADIR%%/lib/tk8.4/optMenu.tcl
+%%DATADIR%%/lib/tk8.4/palette.tcl
+%%DATADIR%%/lib/tk8.4/panedwindow.tcl
+%%DATADIR%%/lib/tk8.4/pkgIndex.tcl
+%%DATADIR%%/lib/tk8.4/safetk.tcl
+%%DATADIR%%/lib/tk8.4/scale.tcl
+%%DATADIR%%/lib/tk8.4/scrlbar.tcl
+%%DATADIR%%/lib/tk8.4/spinbox.tcl
+%%DATADIR%%/lib/tk8.4/tearoff.tcl
+%%DATADIR%%/lib/tk8.4/text.tcl
+%%DATADIR%%/lib/tk8.4/tk.tcl
+%%DATADIR%%/lib/tk8.4/tkfbox.tcl
+%%DATADIR%%/lib/tk8.4/unsupported.tcl
+%%DATADIR%%/lib/tk8.4/xmfbox.tcl
+%%DATADIR%%/tcl/ac3d.tcl
+%%DATADIR%%/tcl/ac3dfsbox.tcl
+%%DATADIR%%/tcl/ac3dhier.tcl
+%%DATADIR%%/tcl/ac3dkeys.tcl
+%%DATADIR%%/tcl/ac3dobject.tcl
+%%DATADIR%%/tcl/ac3dobjlib.tcl
+%%DATADIR%%/tcl/ac3dops.tcl
+%%DATADIR%%/tcl/ac3dpalette.tcl
+%%DATADIR%%/tcl/ac3dplugins.tcl
+%%DATADIR%%/tcl/ac3dprefs.tcl
+%%DATADIR%%/tcl/ac3drender.tcl
+%%DATADIR%%/tcl/ac3dtips.tcl
+%%DATADIR%%/tcl/ac3dttfont.tcl
+%%DATADIR%%/tcl/ac3dutil.tcl
+%%DATADIR%%/tcl/ac3duvedit.tcl
+%%DATADIR%%/tcl/ac3dview.tcl
+%%DATADIR%%/tcl/combobox.tcl
+%%DATADIR%%/tcl/toolbar.tcl
+%%DATADIR%%/tcl/tickempty.xbm
+%%DATADIR%%/tcl/tilt.xbm
+%%DATADIR%%/tcl/images/block.gif
+%%DATADIR%%/tcl/images/box.gif
+%%DATADIR%%/tcl/images/cylinder.gif
+%%DATADIR%%/tcl/images/disk.gif
+%%DATADIR%%/tcl/images/ellipse.gif
+%%DATADIR%%/tcl/images/extrude.gif
+%%DATADIR%%/tcl/images/gridx.gif
+%%DATADIR%%/tcl/images/group.gif
+%%DATADIR%%/tcl/images/inspect.gif
+%%DATADIR%%/tcl/images/light.gif
+%%DATADIR%%/tcl/images/line.gif
+%%DATADIR%%/tcl/images/maxmin.gif
+%%DATADIR%%/tcl/images/mesh.gif
+%%DATADIR%%/tcl/images/movesize.gif
+%%DATADIR%%/tcl/images/object.gif
+%%DATADIR%%/tcl/images/pan.gif
+%%DATADIR%%/tcl/images/polygon.gif
+%%DATADIR%%/tcl/images/polyline.gif
+%%DATADIR%%/tcl/images/rect.gif
+%%DATADIR%%/tcl/images/rotate.gif
+%%DATADIR%%/tcl/images/sphere.gif
+%%DATADIR%%/tcl/images/spin.gif
+%%DATADIR%%/tcl/images/surface.gif
+%%DATADIR%%/tcl/images/tick.gif
+%%DATADIR%%/tcl/images/tinygroup.gif
+%%DATADIR%%/tcl/images/tinyhidden0.gif
+%%DATADIR%%/tcl/images/tinyhidden1.gif
+%%DATADIR%%/tcl/images/tinylight.gif
+%%DATADIR%%/tcl/images/tinylocked0.gif
+%%DATADIR%%/tcl/images/tinylocked1.gif
+%%DATADIR%%/tcl/images/tinysphere.gif
+%%DATADIR%%/tcl/images/vertex.gif
+%%DATADIR%%/tcl/images/viewall.gif
+%%DATADIR%%/tcl/images/viewbottomleft.gif
+%%DATADIR%%/tcl/images/viewbottomright.gif
+%%DATADIR%%/tcl/images/viewtopleft.gif
+%%DATADIR%%/tcl/images/viewtopright.gif
+%%DATADIR%%/tcl/images/walk.gif
+%%DATADIR%%/tcl/images/zoom.gif
+%%DATADIR%%/font.ac
+%%DATADIR%%/fontwire.ac
+%%DATADIR%%/plugins/DirectX.p
+%%DATADIR%%/plugins/LDraw.p
+%%DATADIR%%/plugins/airfoil_import.p
+%%DATADIR%%/plugins/centre.p
+%%DATADIR%%/plugins/csg.p
+%%DATADIR%%/plugins/ddsload.p
+%%DATADIR%%/plugins/dxf_export.p
+%%DATADIR%%/plugins/field_import.p
+%%DATADIR%%/plugins/greeble.p
+%%DATADIR%%/plugins/jpegload.p
+%%DATADIR%%/plugins/knife.p
+%%DATADIR%%/plugins/linecom.p
+%%DATADIR%%/plugins/lwexport.p
+%%DATADIR%%/plugins/lwimport.p
+%%DATADIR%%/plugins/milkshape_export.p
+%%DATADIR%%/plugins/milkshape_import.p
+%%DATADIR%%/plugins/obj_export.p
+%%DATADIR%%/plugins/obj_import.p
+%%DATADIR%%/plugins/off_import.p
+%%DATADIR%%/plugins/pngload.p
+%%DATADIR%%/plugins/point_import.p
+%%DATADIR%%/plugins/ppmload.p
+%%DATADIR%%/plugins/quakemap_export.p
+%%DATADIR%%/plugins/savepng.p
+%%DATADIR%%/plugins/smf_export.p
+%%DATADIR%%/plugins/smf_import.p
+%%DATADIR%%/plugins/stl_import.p
+%%DATADIR%%/plugins/t3d_export.p
+%%DATADIR%%/plugins/tgaload.p
+%%DATADIR%%/plugins/tiffload.p
+%%DATADIR%%/plugins/uvmap.p
+%%DATADIR%%/plugins/x3d_export.p
+%%DATADIR%%/plugins/DirectX.tcl
+%%DATADIR%%/plugins/LDraw.tcl
+%%DATADIR%%/plugins/centre.tcl
+%%DATADIR%%/plugins/csg.tcl
+%%DATADIR%%/plugins/font3d.tcl
+%%DATADIR%%/plugins/greeble.tcl
+%%DATADIR%%/plugins/knife.tcl
+%%DATADIR%%/plugins/polymaker.tcl
+%%DATADIR%%/plugins/uvmap.tcl
+%%DATADIR%%/plugins/xdx_export.tcl
%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/top_files
%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/man_files
%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/tcl
-@dirrm %%DATADIR%%/plugins
+@dirrm %%EXAMPLESDIR%%
@dirrm %%DATADIR%%/lib/tk8.4
@dirrm %%DATADIR%%/lib/tcl8.4
@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/tcl/images
+@dirrm %%DATADIR%%/tcl
+@dirrm %%DATADIR%%/plugins
@dirrm %%DATADIR%%