aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-ac3d
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /graphics/linux-ac3d
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Notes
Diffstat (limited to 'graphics/linux-ac3d')
-rw-r--r--graphics/linux-ac3d/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/graphics/linux-ac3d/Makefile b/graphics/linux-ac3d/Makefile
index c16e8e0bdae0..859d18490de8 100644
--- a/graphics/linux-ac3d/Makefile
+++ b/graphics/linux-ac3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ac3d
PORTVERSION= 5.0.21
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://inivis.swmirror.com/
PKGNAMEPREFIX= linux-
@@ -16,19 +17,20 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ip@doom.homeunix.org
COMMENT= Easy to use and powerful 3D graphics modeller (trial version)
-.ifdef(INSTALL_DYNLINKED_VERSION)
-LIB_DEPENDS= ${LINUXBASE}/usr/libGLU.so.1:${PORTSDIR}/graphics/linux_mesa3
-.endif
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs \
+RUN_DEPENDS= \
${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png10 \
${LINUXBASE}/usr/lib/libtiff.so.3:${PORTSDIR}/graphics/linux-tiff
+.ifdef(INSTALL_DYNLINKED_VERSION)
+RUN_DEPENDS+= ${LINUXBASE}/usr/libGLU.so.1:${PORTSDIR}/graphics/linux_mesa3
+.endif
RESTRICTED= "no distribution permitted"
NO_CDROM= ${RESTRICTED}
-NO_BUILD= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}lx
SUB_FILES= pkg-message
@@ -44,10 +46,6 @@ PLIST_SUB= DYNAMIC_VERSION="" \
PROGRAM= ${PORTNAME}
.endif
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
.ifndef(INSTALL_DYNLINKED_VERSION)
pre-everything::
@${ECHO_MSG} 'Define INSTALL_DYNLINKED_VERSION=yes to install'
@@ -57,6 +55,9 @@ pre-everything::
@${ECHO_MSG} ''
.endif
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/${PROGRAM}
+
pre-install:
# Generate startup script
@${ECHO_CMD} "#!${SH}" > ${WRKDIR}/${PORTNAME}.sh