aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-c6-glx-utils
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-11-11 13:06:39 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-11-11 13:06:39 +0000
commit80b6c31429376f1dbdb245cc28ae641a3177f8fa (patch)
treef6afff664949229557403f2ab9f595530366c4cc /graphics/linux-c6-glx-utils
parent29be7efb7b426067a1401882858a8c0807558c0e (diff)
downloadports-80b6c31429376f1dbdb245cc28ae641a3177f8fa.tar.gz
ports-80b6c31429376f1dbdb245cc28ae641a3177f8fa.zip
Notes
Diffstat (limited to 'graphics/linux-c6-glx-utils')
-rw-r--r--graphics/linux-c6-glx-utils/Makefile37
-rw-r--r--graphics/linux-c6-glx-utils/distinfo.i6864
-rw-r--r--graphics/linux-c6-glx-utils/pkg-descr3
3 files changed, 44 insertions, 0 deletions
diff --git a/graphics/linux-c6-glx-utils/Makefile b/graphics/linux-c6-glx-utils/Makefile
new file mode 100644
index 000000000000..0b23003146dd
--- /dev/null
+++ b/graphics/linux-c6-glx-utils/Makefile
@@ -0,0 +1,37 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= glx-utils
+PORTVERSION= 10.1.2
+CATEGORIES= graphics linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= RPM of the GLX utils (Linux CentOS ${LINUX_DIST_VER})
+
+DIST_SUBDIR= rpm/${LINUX_RPM_ARCH}/centos/${LINUX_DIST_VER}
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+RPMVERSION= 2.el6
+BRANDELF_DIRS= usr/bin
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= NVIDIA_GL
+NVIDIA_GL_DESC= Use GL driver from nvidia-driver
+NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+
+PLIST_FILES= usr/bin/glxgears usr/bin/glxinfo \
+ usr/bin/xdriinfo usr/share/man/man1/xdriinfo.1.gz
+
+.if defined(PACKAGE_BUILDING)
+SRC_DISTFILES= mesa-10.1.2-2.el6.src.rpm
+.endif
+
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MNVIDIA_GL}
+USE_LINUX_APPS+= dri
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-c6-glx-utils/distinfo.i686 b/graphics/linux-c6-glx-utils/distinfo.i686
new file mode 100644
index 000000000000..c5ba90d9fae4
--- /dev/null
+++ b/graphics/linux-c6-glx-utils/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.6/glx-utils-10.1.2-2.el6.i686.rpm) = d3869360deb7613846b875c213e40d4bccfe0d1bc8056df63c580d99764829f9
+SIZE (rpm/i686/centos/6.6/glx-utils-10.1.2-2.el6.i686.rpm) = 24912
+SHA256 (rpm/i686/centos/6.6/mesa-10.1.2-2.el6.src.rpm) = eecc2fcd5f3478d420a2decb61e201c91c8cfcaf3ae2bf7e6c5b69d342a5d98c
+SIZE (rpm/i686/centos/6.6/mesa-10.1.2-2.el6.src.rpm) = 23953214
diff --git a/graphics/linux-c6-glx-utils/pkg-descr b/graphics/linux-c6-glx-utils/pkg-descr
new file mode 100644
index 000000000000..156c1a82e80f
--- /dev/null
+++ b/graphics/linux-c6-glx-utils/pkg-descr
@@ -0,0 +1,3 @@
+This package contains among others glxinfo and glxgears.
+
+WWW: http://www.centos.org