aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-f10-gdk-pixbuf/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-11-03 22:30:00 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-11-03 22:30:00 +0000
commit97814184a74f54140ca23ecf22c9febc13cfb5b5 (patch)
tree4f6fcfe964e6ed37ed784918d83c21d0efb6dc82 /graphics/linux-f10-gdk-pixbuf/Makefile
parent1a8b79d702dead572dc28b56c5724c772ec59bb3 (diff)
downloadports-97814184a74f54140ca23ecf22c9febc13cfb5b5.tar.gz
ports-97814184a74f54140ca23ecf22c9febc13cfb5b5.zip
Notes
Diffstat (limited to 'graphics/linux-f10-gdk-pixbuf/Makefile')
-rw-r--r--graphics/linux-f10-gdk-pixbuf/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/graphics/linux-f10-gdk-pixbuf/Makefile b/graphics/linux-f10-gdk-pixbuf/Makefile
index aed29754ab09..d8404bd796d8 100644
--- a/graphics/linux-f10-gdk-pixbuf/Makefile
+++ b/graphics/linux-f10-gdk-pixbuf/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= gdk-pixbuf
-PORTVERSION= 0.8.0.7
-PORTREVISION= 1
+PORTVERSION= 0.22.0.11.3.5
CATEGORIES= graphics linux
-MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
-MASTER_SITE_SUBDIR= ${BASEVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
+MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
+MASTER_SITE_SUBDIR=fedora/fedora/${BASEVERSION}/${MACHINE_ARCH}/RPMS.updates/
PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.([^\.]+)$/-\1/}.${MACHINE_ARCH}
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+)\./\1-/}.${MACHINE_ARCH}
EXTRACT_SUFX= .rpm
EXTRACT_ONLY=
@@ -21,20 +20,16 @@ COMMENT= Linux version of the graphic library for GTK+
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-USE_LINUX_PREFIX= yes
-ONLY_FOR_ARCHS= alpha i386
+USE_LINUX_PREFIX=yes
+ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
-PLIST= ${PKGDIR}/pkg-plist.${MACHINE_ARCH}
-PLIST_SUB= VERSION=${PORTVERSION:C/^(.+)\.[^\.]+$/\1/}
-MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+NO_FILTER_SHLIBS=yes
+PLIST_SUB= VERSION=${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+).+/\1/}
-# Let's avoid hardcoding 'en' as the language.
-LANG= en
-# Set the version of linux_base
-BASEVERSION?= 7.1
-RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm \
+# Set the version of Fedora Core
+BASEVERSION?= 2
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm\
--nodeps --replacepkgs
do-install: