aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-panorama-tools
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2007-11-24 18:21:00 +0000
committerVasil Dimov <vd@FreeBSD.org>2007-11-24 18:21:00 +0000
commit688d975973d0784a9a01692e5844b58987d0576b (patch)
tree49b9b5c312cb1429adfad470567ad88a028fc749 /graphics/linux-panorama-tools
parente1977e85c9aa24fe1c456f9fe9a6c6b02b45e6ce (diff)
Notes
Diffstat (limited to 'graphics/linux-panorama-tools')
-rw-r--r--graphics/linux-panorama-tools/Makefile20
-rw-r--r--graphics/linux-panorama-tools/pkg-plist9
2 files changed, 12 insertions, 17 deletions
diff --git a/graphics/linux-panorama-tools/Makefile b/graphics/linux-panorama-tools/Makefile
index 6262528e9ed6..8b50f35bed40 100644
--- a/graphics/linux-panorama-tools/Makefile
+++ b/graphics/linux-panorama-tools/Makefile
@@ -13,7 +13,7 @@
PORTNAME= linux-panorama-tools
PORTVERSION= 2.6b1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://www.all-in-one.ee/~dersch/
DISTNAME= PanoTools
@@ -23,22 +23,20 @@ COMMENT= Software to View, Create, Edit and Remap Panoramic Images
RUN_DEPENDS= ${LINUXBASE}/usr/bin/jpegtran:${PORTSDIR}/graphics/linux-jpeg \
${LINUXBASE}/usr/lib/libtiff.so.3:${PORTSDIR}/graphics/linux-tiff \
- ${LINUXBASE}/usr/lib/libpng12.so.0:${PORTSDIR}/graphics/linux-png
+ ${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png10
NO_BUILD= yes
+USE_LINUX_PREFIX=yes
+USE_LDCONFIG= yes
+# USE_LINUX is supposed to be defined automatically when USE_LINUX_PREFIX and
+# USE_LDCONFIG are defined but it is not :-/
USE_LINUX= yes
WRKSRC= ${WRKDIR}/PTLinux
-PROGRAM= Helpers/PTStitcher
do-install:
- ${MKDIR} ${PREFIX}/${PORTNAME}/lib
- ${MKDIR} ${PREFIX}/${PORTNAME}/bin
- ${CP} ${WRKSRC}/${PROGRAM} ${PREFIX}/${PORTNAME}/bin
- ${CHMOD} 555 ${PREFIX}/${PORTNAME}/bin/PTStitcher
- ${CP} ${WRKSRC}/libpano12.so ${PREFIX}/${PORTNAME}/lib
- ${CHMOD} 555 ${PREFIX}/${PORTNAME}/lib/libpano12.so
- ${LN} -s ${PREFIX}/${PORTNAME}/bin/PTStitcher ${PREFIX}/bin/PTStitcher
- ${LINUXBASE}/sbin/ldconfig ${PREFIX}/${PORTNAME}/lib/
+ ${INSTALL_PROGRAM} ${WRKSRC}/Helpers/PTStitcher ${PREFIX}/usr/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/libpano12.so ${PREFIX}/usr/lib/
+ ${LN} -sf ${PREFIX}/usr/bin/PTStitcher ${LOCALBASE}/bin/
.include <bsd.port.mk>
diff --git a/graphics/linux-panorama-tools/pkg-plist b/graphics/linux-panorama-tools/pkg-plist
index 04c497cd3a21..9e93827c8f20 100644
--- a/graphics/linux-panorama-tools/pkg-plist
+++ b/graphics/linux-panorama-tools/pkg-plist
@@ -1,6 +1,3 @@
-bin/PTStitcher
-linux-panorama-tools/bin/PTStitcher
-linux-panorama-tools/lib/libpano12.so
-@dirrm linux-panorama-tools/bin
-@dirrm linux-panorama-tools/lib
-@dirrm linux-panorama-tools
+usr/bin/PTStitcher
+usr/lib/libpano12.so
+@unexec rm %%LOCALBASE%%/bin/PTStitcher