aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux_glide
diff options
context:
space:
mode:
authorMartin Cracauer <cracauer@FreeBSD.org>1998-10-08 15:33:46 +0000
committerMartin Cracauer <cracauer@FreeBSD.org>1998-10-08 15:33:46 +0000
commitafd8ab948b670f51915dc76503dedbb85ea790bd (patch)
tree11667831c8047d2aa61bd10206a0bf300c608efa /graphics/linux_glide
parentb2ebc1f9aaaab4ed7c04b0dfe654b390cb69115a (diff)
downloadports-afd8ab948b670f51915dc76503dedbb85ea790bd.tar.gz
ports-afd8ab948b670f51915dc76503dedbb85ea790bd.zip
Notes
Diffstat (limited to 'graphics/linux_glide')
-rw-r--r--graphics/linux_glide/Makefile34
-rw-r--r--graphics/linux_glide/distinfo1
-rw-r--r--graphics/linux_glide/pkg-comment1
-rw-r--r--graphics/linux_glide/pkg-descr18
-rw-r--r--graphics/linux_glide/pkg-plist12
5 files changed, 66 insertions, 0 deletions
diff --git a/graphics/linux_glide/Makefile b/graphics/linux_glide/Makefile
new file mode 100644
index 000000000000..58ccfa5bcf7b
--- /dev/null
+++ b/graphics/linux_glide/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: linux_glide
+# Version required: 2.4
+# Date created: Oct, 8, 1998
+# Whom: cracauer@cons.org "Martin Cracauer"
+#
+# $Id: Makefile,v 1.6 1998/06/27 05:19:06 asami Exp $
+#
+#
+
+DISTNAME= linux_glide_2_4
+PKGNAME= linux_glide-2.4
+CATEGORIES= emulators graphics
+MASTER_SITES= http://www.3dfx.com/software/ \
+ ftp://ftp.3dfx.com/pub/glide/
+
+MAINTAINER= cracauer@cons.org
+
+PREFIX= /compat/linux/usr
+NO_MTREE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/Glide2.4
+
+pre-install:
+ @[ -d ${PREFIX} ] || ${MKDIR} ${PREFIX}
+
+do-install:
+ @zcat ${WRKSRC}/dist.tar.gz | \
+ (cd ${PREFIX}; tar fx - lib include bin/test00)
+ ${MV} ${PREFIX}/bin/test00 ${PREFIX}/bin/test-glide
+
+post-install:
+ -/compat/linux/sbin/ldconfig
+
+.include <bsd.port.mk>
diff --git a/graphics/linux_glide/distinfo b/graphics/linux_glide/distinfo
new file mode 100644
index 000000000000..b57636553bce
--- /dev/null
+++ b/graphics/linux_glide/distinfo
@@ -0,0 +1 @@
+MD5 (linux_glide_2_4.tar.gz) = 89751e44a7878de3b3fb063f2e987e30
diff --git a/graphics/linux_glide/pkg-comment b/graphics/linux_glide/pkg-comment
new file mode 100644
index 000000000000..f74e696e1c69
--- /dev/null
+++ b/graphics/linux_glide/pkg-comment
@@ -0,0 +1 @@
+Linux library implementing the GLIDE interface to 3dfx video cards
diff --git a/graphics/linux_glide/pkg-descr b/graphics/linux_glide/pkg-descr
new file mode 100644
index 000000000000..58fa2ab8d862
--- /dev/null
+++ b/graphics/linux_glide/pkg-descr
@@ -0,0 +1,18 @@
+This port installs the Linux version of the glide API, which is used
+to program the 3dfx/voodoo cards.
+
+Only Linux binaries can use this library. If you have a compiled Linux
+program that dynamically links against glide, everything is fine. If
+you want to compile programs yourself, you have to compile them as
+Linux binaries, using the compiler and tools from
+ports/devel/linux_devel.
+
+If your program uses other libraries, all libraries must be Linux
+libraries as well. In the case of Mesa, you can use
+ports/emulators/linux_mesa, which does everything for you. NOTE: The
+Mesa shared library from the Linux quake distributions does not work,
+use the FreeBSD port (although it installs a Linux lib).
+
+A simple test program is installed under /compat/linux/usr/bin/test-glide
+
+Please report problems to freebsd-multimedia@freebsd.org
diff --git a/graphics/linux_glide/pkg-plist b/graphics/linux_glide/pkg-plist
new file mode 100644
index 000000000000..189c14a6393f
--- /dev/null
+++ b/graphics/linux_glide/pkg-plist
@@ -0,0 +1,12 @@
+include/sst1vid.h
+include/3dfx.h
+include/glide.h
+include/texus.h
+include/glidesys.h
+include/glideutl.h
+include/gump.h
+include/linutil.h
+lib/libglide2x.so
+lib/libtexus.so
+bin/test-glide
+@exec /compat/linux/sbin/ldconfig ; true