aboutsummaryrefslogtreecommitdiff
path: root/graphics/luminance/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-07-04 21:43:08 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-07-04 21:43:08 +0000
commitf8faa0d8388a86dd33311e2a65f97250901edc9a (patch)
treef751c0f9ca9d9298d09cbe9b3275d14b62f0d4b4 /graphics/luminance/Makefile
parentcd6295d6fb1d934b03d89036f0c1728237a1e7cb (diff)
downloadports-f8faa0d8388a86dd33311e2a65f97250901edc9a.tar.gz
ports-f8faa0d8388a86dd33311e2a65f97250901edc9a.zip
Notes
Diffstat (limited to 'graphics/luminance/Makefile')
-rw-r--r--graphics/luminance/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index c88ae4f9490f..bbde45eefc97 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qtpfsgui
PORTVERSION= 1.9.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF
@@ -23,23 +24,24 @@ LIB_DEPENDS= exiv2.3:${PORTSDIR}/graphics/exiv2 \
USE_QT_VER= 4
QT_COMPONENTS= corelib gui imageformats \
linguist_build moc_build qmake_build rcc_build uic_build
+INSTALL_TARGET= install_target install_menu install_icon install_i18n
INSTALLS_ICONS= yes
LRELEASE= ${QT_PREFIX}/bin/lrelease-qt4
+.if !defined(NOPORTOOCS)
+INSTALL_TARGET+=install_htmls
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^QMAKE_CXXFLAGS/d ; \
- s|PREFIX =.*$$|PREFIX = ${PREFIX}|g ; \
- /^INSTALLS/s|docs||g' ${WRKSRC}/project.pro
+ s|PREFIX =.*$$|PREFIX = ${PREFIX}|g' ${WRKSRC}/project.pro
.for file in src/MainWindow/mainWindow.cpp \
src/Preferences/preferencesDialog.cpp \
src/TransplantExif/transplant.cpp
- @${REINPLACE_CMD} -e 's|/usr/local/share/qtpfsgui/|${DATADIR}/|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local/share/qtpfsgui/|${DOCSDIR}/|g' \
${WRKSRC}/${file}
.endfor
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e '316s|htmls||' ${WRKSRC}/project.pro
-.endif
do-configure:
@${LRELEASE} ${WRKSRC}/project.pro